Bug 970967 - Display name, Job title shouldn't be required when adding new staff
Display name, Job title shouldn't be required when adding new staff
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Portal Platform 6
Classification: JBoss
Component: Portal (Show other bugs)
6.1.0
Unspecified Unspecified
unspecified Severity unspecified
: ER02
: 6.1.0
Assigned To: Viliam Rockai
vramik
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-05 06:57 EDT by mgottval
Modified: 2015-08-31 23:31 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-07 09:24:01 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
new staff (113.11 KB, image/png)
2013-06-05 06:57 EDT, mgottval
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker GTNPORTAL-3061 Major Resolved Add UserConfigurableValidator for user's job title, user's display name and group label 2013-07-08 04:53:54 EDT

  None (edit)
Description mgottval 2013-06-05 06:57:09 EDT
Created attachment 757123 [details]
new staff

When filling all required fields in New Staff, or Register, there is warning of required field Display name, at New Staff also Job Title.
This fields should be tagged as required, or not be required.


Steps to Reproduce:
1.Log in as Root
2.Go to Group -> Organization -> New Staff
3.Fill in required fields, Save - warning: 
The field "Display Name" is required.
The field "Job Title" is required.

(When Register, there is just Display name required)
Comment 1 Viliam Rockai 2013-06-06 08:42:48 EDT
i cannot replicate the issue, it seems to be already fixed with this commit:
https://github.com/gatein/gatein-portal/commit/71ac9e08ae8089df0396631ebe757a9d9c7be0a2

therefore i'm adding GTNPORTAL-3061 as related external tracker.
Comment 3 vramik 2013-07-04 08:53:16 EDT
Verified in ER02

Note You need to log in before you can comment on or make changes to this bug.