Bug 970976 - Unable to login to SystemDLightWeightContainer
Unable to login to SystemDLightWeightContainer
Status: CLOSED DUPLICATE of bug 966807
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
19
ppc64 All
unspecified Severity high
: ---
: ---
Assigned To: systemd-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-05 07:31 EDT by IBM Bug Proxy
Modified: 2013-06-07 02:55 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-07 02:55:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
IBM Linux Technology Center 94297 None None None Never

  None (edit)
Description IBM Bug Proxy 2013-06-05 07:31:14 EDT
Steps to reproduce:
----------------------------------
1) Install Fedora 19 Beta code
2)Trunoff audit
3)Create a container 
4)change the passwd for teh container
5)Reboot the container
6)login fails

Followed below steps to create SystemDLightWeightContainer:
1)Install Fedora 19 Beta build

2)Turnoff audit

3)Create a mycontainer
yum -y --releasever=19 --nogpg --installroot=/srv/mycontainer --disablerepo='*' --enablerepo=fedora install systemd passwd yum fedora-release vim-minimal

fedora                                                   | 4.2 kB     00:00
fedora/primary_db                                          |  16 MB   00:00
Resolving Dependencies
--> Running transaction check
---> Package fedora-release.noarch 0:19-0.5 will be installed
---> Package passwd.ppc64 0:0.78.99-4.fc19 will be installed
--> Processing Dependency: pam >= 1.0.90 for package: passwd-0.78.99-4.fc19.ppc64

....
....

Complete!

[root@c57f1ju0203 ~]# systemd-nspawn -D /srv/mycontainer
Spawning namespace container on /srv/mycontainer (console is /dev/pts/0).
Init process in the container running as PID 1328.

-bash-4.2# passwd
Changing password for user root.
New password:
BAD PASSWORD: The password is shorter than 7 characters
Retype new password:
passwd: all authentication tokens updated successfully.

-bash-4.2# exit
logout

[root@c57f1ju0203 ~]# systemd-nspawn -bD /srv/mycontainer 3
Spawning namespace container on /srv/mycontainer (console is /dev/pts/0).
Init process in the container running as PID 1354.
systemd 204 running in system mode. (+PAM +LIBWRAP +AUDIT +SELINUX +IMA +SYSVINI                                                                                                                      T +LIBCRYPTSETUP +GCRYPT +ACL +XZ)
Detected virtualization 'systemd-nspawn'.

Welcome to Fedora 19 (Schr??dinger?s Cat)!

Initializing machine ID from random generator.
[  OK  ] Reached target Remote File Systems.
[  OK  ] Listening on Delayed Shutdown Socket.
[  OK  ] Listening on /dev/initctl Compatibility Named Pipe.
[  OK  ] Reached target Encrypted Volumes.
[  OK  ] Reached target Paths.
[  OK  ] Listening on Journal Socket.
         Mounting Huge Pages File System...
         Mounting POSIX Message Queue File System...
         Mounting Configuration File System...
         Mounting Debug File System...
         Starting Journal Service...
[  OK  ] Started Journal Service.
[  OK  ] Reached target Swap.
[  OK  ] Reached target Local File Systems (Pre).
         Starting Load Random Seed...
         Mounting Temporary Directory...
[  OK  ] Mounted Huge Pages File System.
[  OK  ] Mounted POSIX Message Queue File System.
[  OK  ] Mounted Configuration File System.
[  OK  ] Mounted Debug File System.
[  OK  ] Mounted Temporary Directory.
[  OK  ] Reached target Local File Systems.
         Starting Recreate Volatile Files and Directories...
         Starting Trigger Flushing of Journal to Persistent Storage...
[  OK  ] Started Load Random Seed.
[  OK  ] Started Trigger Flushing of Journal to Persistent Storage.
[  OK  ] Started Recreate Volatile Files and Directories.
[  OK  ] Reached target System Initialization.
[  OK  ] Listening on D-Bus System Message Bus Socket.
[  OK  ] Reached target Sockets.
[  OK  ] Reached target Timers.
[  OK  ] Reached target Basic System.
         Starting Login Service...
         Starting D-Bus System Message Bus...
[  OK  ] Started D-Bus System Message Bus.
         Starting Permit User Sessions...
[  OK  ] Started Permit User Sessions.
         Starting Console Getty...
[  OK  ] Started Console Getty.
[  OK  ] Reached target Login Prompts.
[  OK  ] Started Login Service.
[  OK  ] Reached target Multi-User System.

Fedora release 19 (Schr??dinger?s Cat)
Kernel 3.9.4-300.fc19.ppc64p7 on an ppc64 (console)

mycontainer login: root
Password:

Cannot make/remove an entry for the specified session

Fedora release 19 (Schr??dinger?s Cat)
Kernel 3.9.4-300.fc19.ppc64p7 on an ppc64 (console)

mycontainer login:

== Comment: #1 - Kalpana Shetty <kalshett@in.ibm.com> - 2013-05-31 05:23:37 ==
System Access:
9.114.32.144; root/.pasroot

[root@c57f1ju0203 network-scripts]# cat /etc/issue
Fedora release 19 (Schr??dinger?s Cat)
Kernel \r on an \m (\l)

[root@c57f1ju0203 network-scripts]# uname -a
Linux c57f1ju0203.ppd.pok.ibm.com 3.9.4-300.fc19.ppc64p7 #1 SMP Sun May 26 22:14:56 MST 2013 ppc64 ppc64 ppc64 GNU/Linux

[root@c57f1ju0204 ~]# lscpu
Architecture:          ppc64
CPU op-mode(s):        32-bit, 64-bit
Byte Order:            Big Endian
CPU(s):                8
On-line CPU(s) list:   0-7
Thread(s) per core:    4
Core(s) per socket:    1
Socket(s):             2
NUMA node(s):          1
Model:                 IBM,8246-L2B
L1d cache:             32K
L1i cache:             32K
L2 cache:              256K
L3 cache:              4096K
NUMA node0 CPU(s):     0-7


== Comment: # - Vaishnavi Bhat <vaish123@in.ibm.com> -  ==
FYI, 

RedHat bugzilla: https://bugzilla.redhat.com/show_bug.cgi?id=966807 addresses the similar issue about login issue systemd lightweight container.

== Comment: # - Kalpana Shetty <kalshett@in.ibm.com> - ==
(In reply to comment #2)
> Hi Kalpana, 
> 
> Have you rebooted your host after turning off the audit ? 
> You need to boot your host with audit=0 on the kernel command line.
> 
> Thanks.

Yes; I have reboot the lpar after disabling audit=0;
Here is the /proc/cmdline o/p:
[root@c57f1ju0203 ~]# cat /proc/cmdline
BOOT_IMAGE=/vmlinuz-3.9.4-300.fc19.ppc64p7 root=/dev/mapper/fedora-root ro rd.lvm.lv=fedora/swap rd.md=0 rd.dm=0 vconsole.keymap=us rd.lvm.lv=fedora/root rd.luks=0 LANG=en_US.UTF-8 crashkernel=128M audit=0
Comment 1 Ondrej Vasik 2013-06-05 09:27:55 EDT
Basesystem is just dependency metapackage with no content - I'll move that to systemd.
Comment 2 Lennart Poettering 2013-06-07 02:55:48 EDT

*** This bug has been marked as a duplicate of bug 966807 ***

Note You need to log in before you can comment on or make changes to this bug.