Bug 971021 - Some icons in collection bubbles are not visible
Some icons in collection bubbles are not visible
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gnome-shell (Show other bugs)
19
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Owen Taylor
Fedora Extras Quality Assurance
AcceptedBlocker
: Reopened
Depends On:
Blocks: F19Blocker/F19FinalBlocker
  Show dependency treegraph
 
Reported: 2013-06-05 09:24 EDT by Jiri Eischmann
Modified: 2013-06-13 02:42 EDT (History)
7 users (show)

See Also:
Fixed In Version: gnome-settings-daemon-3.8.3-2.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-13 02:42:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Some icons are not visible in the collection bubble (1.25 MB, image/png)
2013-06-05 09:24 EDT, Jiri Eischmann
no flags Details

  None (edit)
Description Jiri Eischmann 2013-06-05 09:24:21 EDT
Created attachment 757185 [details]
Some icons are not visible in the collection bubble

When I opened "Tools" collection bubble in Fedora 19, some icons weren't
visible because the upper border of the bubble was out of the grid area. There
was also no way to scroll in the bubble.

The algorithm to render the collection bubble should make sure all icons are
visible or there is be a scrollbar in the bubble.

I'm attaching a screenshot of it.

I already reported it upstream (https://bugzilla.gnome.org/show_bug.cgi?id=701648), but I opened a bug here, too, to track the problem downstream.
Comment 1 Florian Müllner 2013-06-05 10:06:29 EDT
This has been fixed upstream on both master and 3-8 branch. We plan to do a 3.8.3 upstream release these days, so the fix should make it into Fedora soon.
Comment 2 Jiri Eischmann 2013-06-06 04:35:44 EDT
This bug most likely meets blocker bug criteria for F19 Final, so I'm proposing it as a blocker bug to make sure that the fix will land in F19 before the final release. I'm reopening the bug report for tracking in the blocker bug process.
Comment 3 Adam Williamson 2013-06-10 14:33:23 EDT
Discussed at 2013-06-10 blocker review meeting: http://meetbot.fedoraproject.org/fedora-blocker-review/2013-06-10/f19final-blocker-review-4.2013-06-10-16.01.log.txt . Accepted as a blocker under the spirit of the criterion "All applications listed under the Applications menu or category must start successfully" - that wording was somewhat GNOME 2-specific, but we agreed that we think part of the spirit of the overall 'menu sanity' criteria included 'everything that's supposed to be launchable from the menus actually should be'.

I'll try and incorporate this into the re-write of the Final criteria that's currently in progress.
Comment 4 Fedora Update System 2013-06-10 16:13:03 EDT
gnome-shell-3.8.3-1.fc19, mutter-3.8.3-1.fc19, gnome-settings-daemon-3.8.3-1.fc19, control-center-3.8.3-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/gnome-shell-3.8.3-1.fc19,mutter-3.8.3-1.fc19,gnome-settings-daemon-3.8.3-1.fc19,control-center-3.8.3-1.fc19
Comment 5 Fedora Update System 2013-06-11 13:57:54 EDT
Package gnome-settings-daemon-3.8.3-2.fc19, gnome-shell-3.8.3-1.fc19, mutter-3.8.3-1.fc19, control-center-3.8.3-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gnome-settings-daemon-3.8.3-2.fc19 gnome-shell-3.8.3-1.fc19 mutter-3.8.3-1.fc19 control-center-3.8.3-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-10587/gnome-shell-3.8.3-1.fc19,mutter-3.8.3-1.fc19,gnome-settings-daemon-3.8.3-2.fc19,control-center-3.8.3-1.fc19
then log in and leave karma (feedback).
Comment 6 Jiri Eischmann 2013-06-12 09:08:20 EDT
The bug seems to be fixed with the update. I gave it a + karma.
Comment 7 Fedora Update System 2013-06-13 02:42:51 EDT
gnome-settings-daemon-3.8.3-2.fc19, gnome-shell-3.8.3-1.fc19, mutter-3.8.3-1.fc19, control-center-3.8.3-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.