Bug 971042 - libreoffice-debuginfo cannot be unpacked; abrt reporting dies on its ass
libreoffice-debuginfo cannot be unpacked; abrt reporting dies on its ass
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: abrt (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Michal Toman
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-05 10:13 EDT by David Tonhofer
Modified: 2015-03-22 20:41 EDT (History)
15 users (show)

See Also:
Fixed In Version: gnome-abrt-0.3.1-1.fc18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-02 02:29:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Tonhofer 2013-06-05 10:13:59 EDT
Description of problem:

Trying to report oo crash with abrt. Log shows:

-----------------
Downloading (1 of 58) libreoffice-debuginfo-3.6.6.2-8.fc18.x86_64.rpm:  94%
Downloading (1 of 58) libreoffice-debuginfo-3.6.6.2-8.fc18.x86_64.rpm:  98%
Downloading (1 of 58) libreoffice-debuginfo-3.6.6.2-8.fc18.x86_64.rpm: 100%
Extracting cpio from /tmp/abrt-tmp-debuginfo-2013-06-05-16:06:09.24148/libreoffice-debuginfo-3.6.6.2-8.fc18.x86_64.rpm
Can't extract package '/tmp/abrt-tmp-debuginfo-2013-06-05-16:06:09.24148/libreoffice-debuginfo-3.6.6.2-8.fc18.x86_64.rpm'
Unpacking failed, aborting download...
-----------------

Version-Release number of selected component (if applicable):

libreoffice-debuginfo-3.6.6.2-8.fc18.x86_64.rpm

How reproducible:

Tried to report 3 times.
Comment 1 David Tardon 2013-06-05 10:28:12 EDT
rpmdev-extract unpacks it just fine
Comment 2 David Tonhofer 2013-06-05 10:47:20 EDT
yum install libreoffice-debuginfo-3.6.6.2-8.fc18.x86_64

works fine, too.
Comment 3 Jiri Moskovcak 2013-06-06 04:11:32 EDT
How big is that unpacked debuginfo? I have a feeling that it fails because your /tmp is too small.
Comment 4 David Tardon 2013-06-06 04:43:06 EDT
Size        : 2696396981
on F-19 (4.1.0.0-2.beta1.fc19)
Comment 5 David Tonhofer 2013-06-06 05:10:07 EDT
> How big is that unpacked debuginfo? I have a feeling that it fails because your /tmp is too small.

Very likely. 2.5G dumped into /tmp is not going to work on Fedora 18.

/tmp is by default installed on the tmpfs and in my case has a size of 2 G

:-(
Comment 6 Michal Toman 2013-08-09 06:55:22 EDT
This has been fixed in upstream, the unpacker will use /var/tmp.

commit 21a3ac3885c5b4e4e0605e12ecd183c118ec1117
Author: Jakub Filak <jfilak@redhat.com>
Date:   Thu Aug 1 18:45:26 2013 +0200

    do not store potentially big data in /tmp
    
    Related to rhbz#990208
    
    Signed-off-by: Jakub Filak <jfilak@redhat.com>
    Signed-off-by: Jiri Moskovcak <jmoskovc@redhat.com>
Comment 7 Fedora Update System 2013-09-13 09:17:31 EDT
gnome-abrt-0.3.1-1.fc18,abrt-2.1.7-1.fc18,libreport-2.1.7-1.fc18,satyr-0.9-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/gnome-abrt-0.3.1-1.fc18,abrt-2.1.7-1.fc18,libreport-2.1.7-1.fc18,satyr-0.9-1.fc18
Comment 8 Fedora Update System 2013-09-13 22:28:59 EDT
Package gnome-abrt-0.3.1-1.fc18, abrt-2.1.7-1.fc18, libreport-2.1.7-1.fc18, satyr-0.9-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gnome-abrt-0.3.1-1.fc18 abrt-2.1.7-1.fc18 libreport-2.1.7-1.fc18 satyr-0.9-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-16676/gnome-abrt-0.3.1-1.fc18,abrt-2.1.7-1.fc18,libreport-2.1.7-1.fc18,satyr-0.9-1.fc18
then log in and leave karma (feedback).
Comment 9 Fedora Update System 2013-10-02 02:29:02 EDT
gnome-abrt-0.3.1-1.fc18, abrt-2.1.7-1.fc18, libreport-2.1.7-1.fc18, satyr-0.9-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.