Bug 971076 - [GSS] (6.3) Module "org.jboss.log4j.logmanager" Needs Dependency On "javax.mail.api" Module
[GSS] (6.3) Module "org.jboss.log4j.logmanager" Needs Dependency On "javax.ma...
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Class Loading (Show other bugs)
6.0.1
All All
medium Severity low
: DR0
: EAP 6.3.0
Assigned To: Mustafa Musaji
:
Depends On:
Blocks: 1051335
  Show dependency treegraph
 
Reported: 2013-06-05 11:37 EDT by Jonathan Mason
Modified: 2014-06-28 11:42 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
In previous versions of JBoss EAP 6, `org.jboss.log4j.logmanager` did not specify its dependency on javax.mail.api in its +module.xml+. This release adds this dependency to the logmanager module.
Story Points: ---
Clone Of:
: 1051335 (view as bug list)
Environment:
Last Closed: 2014-06-28 11:42:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker WFLY-1300 Minor Resolved org.jboss.log4j.logmanager module needs a dependency on javax.mail.api 2016-01-18 06:13 EST

  None (edit)
Description Jonathan Mason 2013-06-05 11:37:00 EDT
Description of problem:

It seems that module org.jboss.log4j.logmanager has a dependency on javax.mail.api, which is not specificed in its module.xml. Some of the log4j appenders (such as SMTPAppender) require java mail api classes. 

Version-Release number of selected component (if applicable):
JBoss EAP 6.0.1

How reproducible:
Very

Steps to Reproduce:
Deploy an application that uses an appender (for example SMTPAppender), which requires java mail api.

Actual results:

13:20:18,105 ERROR [org.jboss.msc.service.fail] (MSC service thread 1-6) MSC000001: Failed to start service jboss.deployment.unit."alpha-server.ear".POST_MODULE: org.jboss.msc.service.StartException in service jboss.deployment.unit."alpha-server.ear".POST_MODULE: JBAS018733: Failed to process phase POST_MODULE of deployment "alpha-server.ear"
...
Caused by: java.lang.ClassNotFoundException: javax.mail.internet.AddressException from [Module "org.jboss.log4j.logmanager:main" from local module loader @192328ef (roots: C:\projects\AFF00RSK\aff00rsksrv01\build\dist\jboss\modules)]
	at org.jboss.modules.ModuleClassLoader.findClass(ModuleClassLoader.java:190)
	at org.jboss.modules.ConcurrentClassLoader.performLoadClassUnchecked(ConcurrentClassLoader.java:468)
	at org.jboss.modules.ConcurrentClassLoader.performLoadClassChecked(ConcurrentClassLoader.java:456)
	at org.jboss.modules.ConcurrentClassLoader.performLoadClass(ConcurrentClassLoader.java:398)
	at org.jboss.modules.ConcurrentClassLoader.loadClass(ConcurrentClassLoader.java:120)
	... 18 more


Expected results:
Dependcy on java mail api classes is met and application sucessfully deploys.


Additional info:
Adding <module name="javax.mail.api"/> as a dependency of module org.jboss.log4j.logmanager resolves this issue.
Comment 1 David M. Lloyd 2013-06-07 14:21:36 EDT
Is there an upstream bug for this one?
Comment 2 Jonathan Mason 2013-06-10 13:32:29 EDT
>Is there an upstream bug for this one?

https://issues.jboss.org/browse/WFLY-1300
Comment 11 Jan Martiska 2014-02-24 08:10:30 EST
Verified in 6.3.0.DR0.
Comment 12 Larry Wilson 2014-05-01 16:03:31 EDT
Jonathan, 

This issue is biting us, too, in EAP 6.2.0. 

Dumb question - 

You mention that "Adding <module name="javax.mail.api"/> as a dependency of module org.jboss.log4j.logmanager resolves this issue."

First time delving into the module stuff here - could you be more specific about where this is added and the correct syntax? 

I've been trying but so far blowing things up pretty well..

Thanks.



(In reply to Jonathan Mason from comment #0)
> Description of problem:
> 
> It seems that module org.jboss.log4j.logmanager has a dependency on
> javax.mail.api, which is not specificed in its module.xml. Some of the log4j
> appenders (such as SMTPAppender) require java mail api classes. 
> 
> Version-Release number of selected component (if applicable):
> JBoss EAP 6.0.1
> 
> How reproducible:
> Very
> 
> Steps to Reproduce:
> Deploy an application that uses an appender (for example SMTPAppender),
> which requires java mail api.
> 
> Actual results:
> 
> 13:20:18,105 ERROR [org.jboss.msc.service.fail] (MSC service thread 1-6)
> MSC000001: Failed to start service
> jboss.deployment.unit."alpha-server.ear".POST_MODULE:
> org.jboss.msc.service.StartException in service
> jboss.deployment.unit."alpha-server.ear".POST_MODULE: JBAS018733: Failed to
> process phase POST_MODULE of deployment "alpha-server.ear"
> ...
> Caused by: java.lang.ClassNotFoundException:
> javax.mail.internet.AddressException from [Module
> "org.jboss.log4j.logmanager:main" from local module loader @192328ef (roots:
> C:\projects\AFF00RSK\aff00rsksrv01\build\dist\jboss\modules)]
> 	at org.jboss.modules.ModuleClassLoader.findClass(ModuleClassLoader.java:190)
> 	at
> org.jboss.modules.ConcurrentClassLoader.
> performLoadClassUnchecked(ConcurrentClassLoader.java:468)
> 	at
> org.jboss.modules.ConcurrentClassLoader.
> performLoadClassChecked(ConcurrentClassLoader.java:456)
> 	at
> org.jboss.modules.ConcurrentClassLoader.
> performLoadClass(ConcurrentClassLoader.java:398)
> 	at
> org.jboss.modules.ConcurrentClassLoader.loadClass(ConcurrentClassLoader.java:
> 120)
> 	... 18 more
> 
> 
> Expected results:
> Dependcy on java mail api classes is met and application sucessfully deploys.
> 
> 
> Additional info:
> Adding <module name="javax.mail.api"/> as a dependency of module
> org.jboss.log4j.logmanager resolves this issue.

Note You need to log in before you can comment on or make changes to this bug.