Bug 971078 - [RHSC] Detach Via Console results in Error (Cluster or Data Center compatibility version)
Summary: [RHSC] Detach Via Console results in Error (Cluster or Data Center compatibil...
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhsc   
(Show other bugs)
Version: 2.1
Hardware: Unspecified Unspecified
medium
unspecified
Target Milestone: ---
: ---
Assignee: Sahina Bose
QA Contact: Matt Mahoney
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-06-05 15:45 UTC by Matt Mahoney
Modified: 2013-09-23 22:25 UTC (History)
6 users (show)

Fixed In Version: bb4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-23 22:25:44 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 15826 None None None Never

Description Matt Mahoney 2013-06-05 15:45:50 UTC
Description of problem:

After doing a peer probe, and then attempting to Detach via Console (Cluster.General.Detach), the following error occurs:

"Error while executing action: The Action remove is not supported for this Cluster or Data Center compatibility version"

Version-Release number of selected component (if applicable):
bb2

How reproducible:


Steps to Reproduce:
1. From Gluster CLI: Peer probe <server>
2. In Console, navigate to Cluster.General
3. Click "Detach" link
4. In "Detach Gluster Hosts" dialog, select server and then click OK.

Actual results:


Expected results:
Server should successfully be detached.

Additional info:

Comment 2 Sahina Bose 2013-06-18 11:43:24 UTC
Detach server was calling RemoveGlusterServer that had a compatibility check for 3.2 level. Removed this is in the upstream patch mentioned.

Comment 3 Matt Mahoney 2013-06-20 19:24:20 UTC
Verified in bb4.

Comment 4 Scott Haines 2013-09-23 22:25:44 UTC
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html


Note You need to log in before you can comment on or make changes to this bug.