Bug 971102 - panic on IPv6 router in pskb_expand_head
panic on IPv6 router in pskb_expand_head
Status: CLOSED DUPLICATE of bug 892060
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-05 12:59 EDT by Felix Kaechele
Modified: 2013-06-28 12:48 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-28 12:48:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Photo of the kernel panic trace (1.26 MB, image/jpeg)
2013-06-05 12:59 EDT, Felix Kaechele
no flags Details

  None (edit)
Description Felix Kaechele 2013-06-05 12:59:19 EDT
Created attachment 757279 [details]
Photo of the kernel panic trace

Description of problem:
The kernel on the router machine (running F18) panics when one of the clients in my network runs the Netalyzer (http://netalyzr.icsi.berkeley.edu/) test.


Set up is as follows:
kernel-3.9.4-200.fc18.x86_64
iptables-1.4.16.2-5.fc18.x86_64
shorewall6-4.5.16.1-1.fc18.noarch

The machine is connected via ADSL PPPoE to the Internet. A SiXXS Tunnel with static endpoint is being used for IPv6 connectivity.
The system uses shorewall/shorewall6 for the firewall.
The network card is a IBM dual-port e1000e.
Comment 1 Felix Kaechele 2013-06-06 11:42:28 EDT
This issue seems to be netfilter related.
It only appears when shorewall6 is started.
It happens during the step "Checking the network's MTU for IPv6" in Netalyzr.
Comment 2 Neil Horman 2013-06-13 15:09:25 EDT
can you post the backtrace please?
Comment 3 Neil Horman 2013-06-28 12:48:19 EDT
Sorry, I missed the backtrace photo.  Looking at it I think its a dup of 892060.  I'm closing this as a dup of that.  If the problem recurs on the latest kernel, please reopen this.  Thanks!

*** This bug has been marked as a duplicate of bug 892060 ***

Note You need to log in before you can comment on or make changes to this bug.