Bug 971189 - Wrong Keyboard Layout for Disk Encryption Prompt
Wrong Keyboard Layout for Disk Encryption Prompt
Status: CLOSED DUPLICATE of bug 994180
Product: Fedora
Classification: Fedora
Component: grubby (Show other bugs)
19
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-05 20:26 EDT by scenefinale
Modified: 2013-12-10 00:37 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-10 00:37:20 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description scenefinale 2013-06-05 20:26:50 EDT
Description of problem:
Startup prompt for encryption password for F19B and F18 uses US layout even though dvorak was selected during install (and US deleted).


Version-Release number of selected component (if applicable):
(I'm not yet familiar enough with the code to tell if the actual issue resides with grubby, anaconda, plymouth, grub2, or something else... Perhaps the bug is not in the suspected programs but rather it is a bad parameter passed from elsewhere which is causing the incorrect behavior).


How reproducible:
%100

Steps to Reproduce:
1. During fresh install of F19B (via live DVD), select DVORAK as keyboard layout, delete US.  Opt for ENCRYPTED install with BTRFS (NOT LVM) and type password in with (using DVORAK layout).
2. Finish Install and reboot.
3. Press 'e' at grub menu to edit the selected kernel's boot parameters. Note that vconsole.keymap is set to an incorrect value.

Actual results:
/boot/grub2/grub.cfg contains a menuentry with vconsole.keymap=us instead of vconsole.keymap=dvorak

Expected results
 linux   /vmlinuz-3.9.2-301.fc19.x86_64 root=UUID=XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXX ro rootflags=subvol=root rd.md=0 rd.lvm=0 rd.dm=0 rd.luks.uuid=luks-XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXX vconsole.keymap=dvorak rd.luks.uuid=luks-XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXX


Additional info:
-Gnome boots to the correct dvorak keyboard layout, even when vconsole.keymap=us. The issue is only during password entry for startup disk encryption.

-Yes I've seen many similar bugs filed but I didn't see any which specifically matched mine.

-I have reproduced this bug in F18 as well.
Comment 1 William Brown 2013-09-12 10:38:59 EDT
I can reproduce this on a clean install of F19 and F20 Alpha RC2
Comment 2 Alejandro von Mankowski 2013-10-03 16:20:41 EDT
It happens with every keyboard layout you choose at installation.
Comment 3 Adam Williamson 2013-12-10 00:37:20 EST
this should be working in current F20 (try Final TC5 at https://dl.fedoraproject.org/pub/alt/stage/20-TC5/ ).

*** This bug has been marked as a duplicate of bug 994180 ***

Note You need to log in before you can comment on or make changes to this bug.