Bug 971204 - REST API changes can potentially break clients, need to avoid changing an existing attribute
REST API changes can potentially break clients, need to avoid changing an exi...
Status: CLOSED CURRENTRELEASE
Product: OpenShift Online
Classification: Red Hat
Component: Master (Show other bugs)
2.x
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Lili Nader
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-05 21:56 EDT by Clayton Coleman
Modified: 2015-05-14 20:54 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-24 10:51:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Clayton Coleman 2013-06-05 21:56:22 EDT
Given that most requests to /broker/rest/api are not version qualified, we cannot change the type of the "versions" value from string to float.

We should introduce a new attribute "api_version" which is a float and leave "version" as a string (in API >= 1.5).

Blocks release
Comment 1 Jordan Liggitt 2013-06-07 12:09:16 EDT
Will our API version always be able to be expressed as a float? e.g. no more than one point version?
Comment 2 Clayton Coleman 2013-06-12 10:43:09 EDT
We cannot exit this sprint with this issue.
Comment 5 zhaozhanqi 2013-06-18 06:00:45 EDT
Tested this issue on devenv_3373, it has been fixed.


             <type>string</type>
              <description>The key portion of an rsa key (excluding ssh-rsa and comment)</description>
              <valid-options/>
              <invalid-options/>
            </param>
          </required-params>
          <optional-params/>
        </link>
      </links>
    </user>
  </data>
  <messages/>
  <version>1.5</version>
  <api-version>1.5</api-version>
  <supported-api-versions>
    <supported-api-version>1.0</supported-api-version>
    <supported-api-version>1.1</supported-api-version>
    <supported-api-version>1.2</supported-api-version>
    <supported-api-version>1.3</supported-api-version>
    <supported-api-version>1.4</supported-api-version>
    <supported-api-version>1.5</supported-api-version>
  </supported-api-versions>
</response>

Note You need to log in before you can comment on or make changes to this bug.