Bug 971228 - crashkernel must be already in place for apply button to work.
crashkernel must be already in place for apply button to work.
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: system-config-kdump (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Martin Milata
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-06 00:06 EDT by Wade Mealing
Modified: 2013-10-08 07:25 EDT (History)
2 users (show)

See Also:
Fixed In Version: system-config-kdump-2.0.13-1.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-08 07:25:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Wade Mealing 2013-06-06 00:06:41 EDT
Description of problem:

Running system-config-kdump on a newly installed system, enabling the service then hitting apply causes the service to fail with a very unusable error message. (Check out sytemctl something something, something or journal -xm)

Version-Release number of selected component (if applicable):

system-config-kdump2.0.10-1.f18

How reproducible:


Steps to Reproduce:
1. Install fedora 18
2. Go through "firstboot" procedure, dont enable kdump
3. Run system-config-kdump, enable, then click apply.

Actual results:

An odd dialog box with 3 expandable options appears.  Its super suspect, at least it tells you what kind of was happening.

Expected results:

Dialog box
-----------------------------------------
The crashkernel parameter was not specified at system boot. This program will modifed the bootloader and the system restarted for this change to take effect:

Would you like these changes made and restarted.

(o) reboot now
( ) Make changes and let the administrator choose when to restart later.

 [ OK ] [ Apply]
------------------------------------------



Additional info:

The original problem goes away, if you just restart, then go back into system-config-kdump after the system restarts and the crashkernel parameter is available the next time the program is run.

TLDR; better error messages when crashkernel parameter is not available.
Comment 1 Martin Milata 2013-07-03 14:11:14 EDT
Thanks for the report.

I commited an upstream change 8978f148559dc27e6648fde0c90ead4ab89da624 that skips starting the kdump service when there's no reserved memory. This way you should not see the error message because the command that produced it is not run.
Comment 2 Fedora Update System 2013-07-10 16:16:42 EDT
system-config-kdump-2.0.12-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/system-config-kdump-2.0.12-1.fc18
Comment 3 Fedora Update System 2013-07-10 16:17:00 EDT
system-config-kdump-2.0.12-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/system-config-kdump-2.0.12-1.fc19
Comment 4 Fedora Update System 2013-07-11 23:13:44 EDT
Package system-config-kdump-2.0.12-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing system-config-kdump-2.0.12-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-12830/system-config-kdump-2.0.12-1.fc19
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2013-09-27 09:23:49 EDT
system-config-kdump-2.0.13-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/system-config-kdump-2.0.13-1.fc18
Comment 6 Fedora Update System 2013-09-27 09:24:06 EDT
system-config-kdump-2.0.13-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/system-config-kdump-2.0.13-1.fc19
Comment 7 Fedora Update System 2013-10-08 07:25:43 EDT
system-config-kdump-2.0.13-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.