Bug 971250 - [abrt] blender-2.67a-1.fc18: generic_run_one: Process /usr/bin/blender was killed by signal 11 (SIGSEGV)
[abrt] blender-2.67a-1.fc18: generic_run_one: Process /usr/bin/blender was ki...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: mesa (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
abrt_hash:f05c94e1c7c5f60ba3ab474bd22...
:
: 974987 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-06 02:30 EDT by Vitaly
Modified: 2013-08-31 19:58 EDT (History)
10 users (show)

See Also:
Fixed In Version: mesa-9.2-0.12.20130610.fc18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-31 19:58:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (18.63 KB, text/plain)
2013-06-06 02:30 EDT, Vitaly
no flags Details
File: cgroup (124 bytes, text/plain)
2013-06-06 02:30 EDT, Vitaly
no flags Details
File: dso_list (8.81 KB, text/plain)
2013-06-06 02:30 EDT, Vitaly
no flags Details
File: environ (1.85 KB, text/plain)
2013-06-06 02:30 EDT, Vitaly
no flags Details
File: limits (1.29 KB, text/plain)
2013-06-06 02:30 EDT, Vitaly
no flags Details
File: maps (52.77 KB, text/plain)
2013-06-06 02:30 EDT, Vitaly
no flags Details
File: open_fds (221 bytes, text/plain)
2013-06-06 02:30 EDT, Vitaly
no flags Details
File: proc_pid_status (951 bytes, text/plain)
2013-06-06 02:30 EDT, Vitaly
no flags Details
File: var_log_messages (1.71 KB, text/plain)
2013-06-06 02:30 EDT, Vitaly
no flags Details
File: xsession_errors (420 bytes, text/plain)
2013-06-06 02:30 EDT, Vitaly
no flags Details

  None (edit)
Description Vitaly 2013-06-06 02:30:00 EDT
Description of problem:
To reproduce (at least on my laptop):

* open some big scene with much polygons in blender

* then enter edit mode with some complex object

* and then switching projection (Num 5 button) causes blender to crash

Version-Release number of selected component:
blender-2.67a-1.fc18

Additional info:
reporter:       libreport-2.1.4
backtrace_rating: 4
cmdline:        blender
core_backtrace: 
crash_function: generic_run_one
executable:     /usr/bin/blender
kernel:         3.9.4-200.fc18.x86_64
runlevel:       N 5
uid:            1000

Truncated backtrace:
Thread no. 1 (10 frames)
 #1 generic_run_one at translate/translate_generic.c:646
 #2 generic_run at translate/translate_generic.c:733
 #3 u_vbuf_translate_buffers at util/u_vbuf.c:428
 #4 u_vbuf_translate_begin at util/u_vbuf.c:599
 #5 u_vbuf_draw_vbo at util/u_vbuf.c:1194
 #6 st_draw_vbo at ../../src/mesa/state_tracker/st_draw.c:286
 #7 vbo_draw_arrays at ../../src/mesa/vbo/vbo_exec_array.c:624
 #8 drawgrid_draw at /usr/src/debug/blender-2.67a/source/blender/editors/space_view3d/view3d_draw.c:260
 #9 view3d_main_area_draw at /usr/src/debug/blender-2.67a/source/blender/editors/space_view3d/view3d_draw.c:411
 #10 ED_region_do_draw at /usr/src/debug/blender-2.67a/source/blender/editors/screen/area.c:432

Potential duplicate: bug 962782
Comment 1 Vitaly 2013-06-06 02:30:07 EDT
Created attachment 757478 [details]
File: backtrace
Comment 2 Vitaly 2013-06-06 02:30:11 EDT
Created attachment 757479 [details]
File: cgroup
Comment 3 Vitaly 2013-06-06 02:30:17 EDT
Created attachment 757480 [details]
File: dso_list
Comment 4 Vitaly 2013-06-06 02:30:21 EDT
Created attachment 757481 [details]
File: environ
Comment 5 Vitaly 2013-06-06 02:30:25 EDT
Created attachment 757482 [details]
File: limits
Comment 6 Vitaly 2013-06-06 02:30:30 EDT
Created attachment 757483 [details]
File: maps
Comment 7 Vitaly 2013-06-06 02:30:34 EDT
Created attachment 757484 [details]
File: open_fds
Comment 8 Vitaly 2013-06-06 02:30:39 EDT
Created attachment 757485 [details]
File: proc_pid_status
Comment 9 Vitaly 2013-06-06 02:30:43 EDT
Created attachment 757486 [details]
File: var_log_messages
Comment 10 Vitaly 2013-06-06 02:30:50 EDT
Created attachment 757487 [details]
File: xsession_errors
Comment 11 Vitaly 2013-06-07 04:01:14 EDT
Tried also blender 2.67b (compiled from source by editing 2.67a spec file) and blender 2.64, got more crashes. I can post backtraces if needed.
Comment 12 Vitaly 2013-06-09 01:49:36 EDT
EDIT:

To reproduce the bug you need to start switching projections (ortho/persp) when some of common views choosen (side/front/back/top etc). So just open blender press Num3, then press Num5 and see if it crashes.
Comment 13 Vitaly 2013-06-09 03:17:45 EDT
Downgrading mesa-dri-drivers (firstly I downloaded mesa-dri-filesystem-9.0.1 x86_64 and i686 from rpmfind.net and installed them with rpm -i --nodeps) 

(I did sudo yum downgrade mesa-dri-drivers mesa-dri-filesystem  mesa-libxatracker{,-devel} llvm-libs)

Should I create bug "mesa-dri-drivers-9.2.0 blender crash" or maybe report to mesa bugtracker?
Comment 14 Vitaly 2013-06-09 03:24:29 EDT
forgot to say, the problem was in mesa-dri-drivers-9.2-0.7.20130528.fc18
Comment 15 Andrew G. Morgan 2013-06-18 23:29:52 EDT
There is a closed bug: 962782 that seems to support it being a mesa issue. It would be much appreciated if whatever magic needs to happen could get into some sort of bug fix for fc18.
Comment 16 Andrew G. Morgan 2013-06-21 01:00:10 EDT
FWIW I downloaded 

http://dl.fedoraproject.org/pub/fedora/linux/development/rawhide/source/SRPMS/m/mesa-9.2-0.12.20130610.fc20.src.rpm

built it and replaced all of the mesa-* packages on my system with those from the built binaries. As suggested in 962782 this resolved the problem with Blender.
Comment 17 Charles 2013-06-24 18:19:46 EDT
Trying to get Blender 2.67 to change to quad view, via shortcut keys or by menu command.

reporter:       libreport-2.1.4
backtrace_rating: 4
cmdline:        blender
crash_function: generic_run_one
executable:     /usr/bin/blender
kernel:         3.9.6-200.fc18.x86_64
package:        blender-2.67a-2.fc18
reason:         Process /usr/bin/blender was killed by signal 11 (SIGSEGV)
reported_to:    uReport: BTHASH=405f90bc2d92b4344d3ed7c2dc7495b77dd1f777
runlevel:       N 5
uid:            1000
Comment 18 Vitaly 2013-07-15 21:32:59 EDT
So would mesa-dri-drivers be updated in fedora-18? Do I miss something that blocks this workaround?
Comment 19 sylvie.andre44 2013-08-24 19:19:35 EDT
See:
http://wiki.blender.org/index.php/Doc:2.6/Manual/Your_First_Animation/1.A_static_Gingerbread_Man

"With Num lock activated, change to the front view with 1 NumPad and to orthogonal view with 5 NumPad."

When selecting orthogonal view, Blender crashes.

reporter:       libreport-2.1.6
backtrace_rating: 4
cmdline:        blender
crash_function: generic_run_one
executable:     /usr/bin/blender
kernel:         3.10.9-100.fc18.x86_64
package:        blender-2.68a-1.fc18
reason:         Process /usr/bin/blender was killed by signal 11 (SIGSEGV)
runlevel:       N 5
uid:            1001
Comment 20 François Cami 2013-08-24 19:41:33 EDT
For the record, I managed to reproduce this bug with Blender 2.68a and 
mesa-9.2-0.7.20130528 on Fedora 18.

Updating mesa to mesa-9.2-0.12.20130610 from koji: http://koji.fedoraproject.org/koji/buildinfo?buildID=432070 fixes it.
=> switching component to mesa.

Adam, Dave, could you please publish mesa-9.2-0.12.20130610.fc18 to updates-testing?
Comment 21 Fedora Update System 2013-08-26 17:29:45 EDT
mesa-9.2-0.12.20130610.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/mesa-9.2-0.12.20130610.fc18
Comment 22 François Cami 2013-08-27 08:28:36 EDT
*** Bug 974987 has been marked as a duplicate of this bug. ***
Comment 23 Fedora Update System 2013-08-27 19:24:02 EDT
Package mesa-9.2-0.12.20130610.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing mesa-9.2-0.12.20130610.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-15352/mesa-9.2-0.12.20130610.fc18
then log in and leave karma (feedback).
Comment 24 François Cami 2013-08-30 17:39:22 EDT
@Vitaly: could you confirm the crash is fixed after the fix in comment 23?
Comment 25 Vitaly 2013-08-31 05:43:51 EDT
@François Cami: 

Sorry, currently I don't have Fedora 18 on any of my systems.

Try to ask sylvie.andre44 and Charles to confirm the fix.
Comment 26 Fedora Update System 2013-08-31 19:58:07 EDT
mesa-9.2-0.12.20130610.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.