Bug 971269 - No IPv6 address configured from kickstart file [NEEDINFO]
No IPv6 address configured from kickstart file
Status: CLOSED EOL
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
24
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Radek Vykydal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-06 03:23 EDT by A.J. Werkman
Modified: 2017-08-08 07:42 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-08 07:42:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rvykydal: needinfo? (aj.werkman)


Attachments (Terms of Use)
anaconda.log (613 bytes, text/plain)
2013-06-06 08:48 EDT, A.J. Werkman
no flags Details
Requested log 2 (9.74 KB, text/plain)
2013-06-06 08:49 EDT, A.J. Werkman
no flags Details
Syslog (114.83 KB, text/plain)
2013-06-06 08:50 EDT, A.J. Werkman
no flags Details

  None (edit)
Description A.J. Werkman 2013-06-06 03:23:40 EDT
Description of problem:
The IPv6 address that is defined in the kickstart file is not configured the the installed system.

Version-Release number of selected component (if applicable):
19-TC1

How reproducible:
Everytime

Steps to Reproduce:
1. Prepare a kickstart file that has a network line to configure IPv4 and IPv6 addresses with '--bootproto static'.
2. Reboot in the installed system
3. View network with ifconfig

Actual results:
Only the IPv4 address is configerd

Expected results:
Both IPv4 and IPv6 addresses are configured

Additional info:
I tried two versions of network definition in my kickstart file:

Version 1:
network --onboot yes --bootproto static --ip 192.168.1.100 --netmask 255.255.255.0 --gateway 192.168.1.1 --nameserver 192.168.1.1 --hostname testsys.digifarma.nl
network --onboot yes --bootproto static --ip 2001:838:xxx:2::100/64 --gateway 2001:838:xxx:2::1 --nameserver 2001:838:xxx:2::1 --hostname testsys.digifarma.nl

Version 2:
network --onboot yes --bootproto static --ip 192.168.1.100 --netmask 255.255.255.0 --gateway 192.168.1.1 --ipv6 2001:838:xxx:2::100 --nameserver 192.168.1.1,2001:838:xxx:2::1 --hostname testsys.digifarma.nl


Both have the same result
Comment 1 Radek Vykydal 2013-06-06 04:27:34 EDT
Version 2 should work but only if you specify --device (or ksdevice boot argument but this may be dropped in future). Not quite sure this is the cause of your case, I'd need to see logs.

Please attach
/tmp/anaconda.log,
/tmp/syslog,
/tmp/ifcfg.log from installer

or
/var/log/anaconda/anaconda.ifcfg.log
/var/log/anaconda/syslog
/var/log/anaconda/anaconda.log
from installed system.
Comment 2 A.J. Werkman 2013-06-06 08:48:38 EDT
Created attachment 757675 [details]
anaconda.log
Comment 3 A.J. Werkman 2013-06-06 08:49:42 EDT
Created attachment 757676 [details]
Requested log 2
Comment 4 A.J. Werkman 2013-06-06 08:50:12 EDT
Created attachment 757677 [details]
Syslog
Comment 5 A.J. Werkman 2013-06-06 08:54:28 EDT
(In reply to Radek Vykydal from comment #1)
> Version 2 should work but only if you specify --device (or ksdevice boot
> argument but this may be dropped in future). Not quite sure this is the
> cause of your case, I'd need to see logs.

The log says: unspecified network --device in kickstart, using em1 (first active device).

This is what I expect. If --device was mandatory it would be impossible to write a generic kickstart file, as nowadays you can't predict how Fedora names it's NICs.
Comment 6 Radek Vykydal 2013-06-06 09:52:17 EDT
The message comes from anaconda whereas the kickstart file is processed (ifcfg file created) in initramfs/dracut part of installer where we currently really don't support missing --device specification.
Comment 7 A.J. Werkman 2014-06-17 16:32:54 EDT
This bug is still present in rawhide:

network --onboot=yes --activate --bootproto=static --ip=212.115.199.60 --netmask=255.255.255.248 --gateway=212.115.199.57 --ipv6=2001:1af8:fe00:847f::4/64 --ipv6gateway=2001:1af8:fe00:847f::1 --nameserver=212.115.199.57,2001:1af8:fe00:847f::1
network --hostname=testsys.digifarma.nl

Becomes:
19:08:39,149 DEBUG ifcfg: content of files (network initialization):
19:08:39,149 DEBUG ifcfg: /etc/sysconfig/network-scripts/ifcfg-p2p1:
19:08:39,149 DEBUG ifcfg:   # Generated by dracut initrd
19:08:39,149 DEBUG ifcfg:   DEVICE="p2p1"
19:08:39,149 DEBUG ifcfg:   ONBOOT=yes
19:08:39,149 DEBUG ifcfg:   NETBOOT=yes
19:08:39,149 DEBUG ifcfg:   UUID="0b891551-69b1-4d8b-ae32-5348daf02cad"
19:08:39,149 DEBUG ifcfg:   BOOTPROTO=none
19:08:39,149 DEBUG ifcfg:   IPADDR="212.115.199.60"
19:08:39,150 DEBUG ifcfg:   NETMASK="255.255.255.248"
19:08:39,150 DEBUG ifcfg:   GATEWAY="212.115.199.57"
19:08:39,150 DEBUG ifcfg:   HWADDR="d8:50:e6:4e:6e:5f"
19:08:39,150 DEBUG ifcfg:   TYPE=Ethernet
19:08:39,150 DEBUG ifcfg:   NAME="p2p1"
19:08:39,150 DEBUG ifcfg:   DNS1="212.115.199.57"
19:08:39,150 DEBUG ifcfg:   DNS2="2001:1af8:fe00:847f::1"
19:08:39,150 DEBUG ifcfg:   DNS3="212.115.199.57"
19:08:39,157 DEBUG ifcfg: all settings: [{'802-3-ethernet': {'s390-options': {}, 'mac-address': [216, 80, 230, 78, 110, 95]}, 'connection': {'timestamp': 1403032114L, 'interface-name': 'p2p1', 'type': '802-3-ethernet', 'id': 'p2p1', 'uuid': '0b891551-69b1-4d8b-ae32-5348daf02cad'}, 'ipv4': {'routes': [], 'address-labels': [''], 'addresses': [[1019704276L, 29L, 969372628L]], 'dns': [969372628L], 'method': 'manual'}, 'ipv6': {'routes': [], 'addresses': [], 'dns': [], 'method': 'ignore'}}]
19:08:39,245 DEBUG ifcfg: IfcfFile.read /etc/sysconfig/network-scripts/ifcfg-p2p1
19:08:39,246 DEBUG ifcfg: IfcfFile.read /etc/sysconfig/network-scripts/ifcfg-p2p1
19:08:39,247 DEBUG ifcfg: IfcfFile.read /etc/sysconfig/network-scripts/ifcfg-p2p1

Looks like anaconda handles IPv4 difrent from IPv6.
IPv4 does not need device, where as IPv6 seems to need this.
Comment 8 Jaroslav Reznik 2015-03-03 09:57:26 EST
This bug appears to have been reported against 'rawhide' during the Fedora 22 development cycle.
Changing version to '22'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora22
Comment 9 A.J. Werkman 2016-04-10 10:45:31 EDT
In 24_Alpha-1.7 this bug is still present.
Comment 10 Radek Vykydal 2016-04-27 09:20:12 EDT
(In reply to A.J. Werkman from comment #9)
> In 24_Alpha-1.7 this bug is still present.

I am not able to reproduce with 24_Alpha-1.7. Could you please attach installation logs?
/tmp/anaconda.log, /tmp/ifcfg.log, /tmp/syslog
Comment 11 Fedora End Of Life 2017-07-25 14:32:59 EDT
This message is a reminder that Fedora 24 is nearing its end of life.
Approximately 2 (two) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 24. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as EOL if it remains open with a Fedora  'version'
of '24'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version'
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not
able to fix it before Fedora 24 is end of life. If you would still like
to see this bug fixed and are able to reproduce it against a later version
of Fedora, you are encouraged  change the 'version' to a later Fedora
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's
lifetime, sometimes those efforts are overtaken by events. Often a
more recent Fedora release includes newer upstream software that fixes
bugs or makes them obsolete.
Comment 12 Fedora End Of Life 2017-08-08 07:42:14 EDT
Fedora 24 changed to end-of-life (EOL) status on 2017-08-08. Fedora 24 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.