Bug 971270 - [RHEV-RHS]: VM moved to paused state due to storage permission error with FSTAT failed
[RHEV-RHS]: VM moved to paused state due to storage permission error with FST...
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterfs (Show other bugs)
2.1
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Pranith Kumar K
spandura
:
Depends On: 873962
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-06 03:24 EDT by Rahul Hinduja
Modified: 2013-09-23 18:35 EDT (History)
5 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0.12rhs.beta6-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-23 18:35:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rahul Hinduja 2013-06-06 03:24:34 EDT
Description of problem:
========================

One of the VM moved into the paused state when a brick was killed in 1*2 replica setup. Client logged a message 
"[2013-06-06 06:25:48.558426] W [fuse-bridge.c:665:fuse_attr_cbk] 0-glusterfs-fuse: 4772448: FSTAT() /cf5fb27d-5ee7-4e59-818f-4927abfbaff6/images/1493c50e-50c6-4f9b-9af4-11db021721c4/1cb0178a-78b4-4a11-b49e-20c8334adf37 => -1 (Transport endpoint is not connected)"

Version-Release number of selected component (if applicable):
=============================================================
# rpm -qa | grep gluster | grep 3.4.0
glusterfs-fuse-3.4.0.8rhs-1.el6rhs.x86_64
glusterfs-geo-replication-3.4.0.8rhs-1.el6rhs.x86_64
glusterfs-rdma-3.4.0.8rhs-1.el6rhs.x86_64
glusterfs-3.4.0.8rhs-1.el6rhs.x86_64
glusterfs-server-3.4.0.8rhs-1.el6rhs.x86_64
# 

Steps Carried:
=============
1. Created 1*2 replica setup from two servers
2. Mounted on Client from RHEVM
3. Created and Started 5 VM's (vm1 to vm5)
4. Brought down server1 (poweroff)
5. Created and started two new VM's (vm6,vm7)
6. Created snapshot of existing VM's (VM1 to VM5)
7. Brought back the server1
8. shd completes self heal.
9. Brought down the brick in server2
10. VM moved into the paused state.

Actual results:
===============

VM moved into the paused state.


Expected results:
=================

VM should not move into the paused state.
Comment 5 Pranith Kumar K 2013-08-08 05:15:06 EDT
Patch to 873962 fixes this. This bug depends on 873962.
Comment 6 Rahul Hinduja 2013-08-28 08:28:54 EDT
Ran the same test case with build: glusterfs-server-3.4.0.24rhs-1.el6rhs.x86_64

All VM's were Up and Running. Marking the bug to verified.
Comment 7 Scott Haines 2013-09-23 18:35:37 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html

Note You need to log in before you can comment on or make changes to this bug.