Bug 97128 - lvcreate won't create logical volume past 2TB.
lvcreate won't create logical volume past 2TB.
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: lvm (Show other bugs)
9
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Heinz Mauelshagen
Brian Brock
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-06-10 13:47 EDT by lnelson
Modified: 2007-03-27 00:06 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-28 09:26:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description lnelson 2003-06-10 13:47:16 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.0.2) Gecko/20030208
Netscape/7.02

Description of problem:
vgcreate was able to create a volume group of 2.22TB from two 1.11TB
raids using: 'vgcreate -s64m VG1 /dev/sdc /dev/sdd'.  According to
my calculations (64m x 65536 = 4.2TB), I should be able to create a
logical volume of up to 4 terabytes using a physical extent of 64m.
However, the command: 'lvcreate -L2.22T -nLV1 VG1' yeilds the error:
 lvcreate -- rounding size up to physical extent boundary
 lvcreate -- size 2383675392 KB is larger than maximum VGDA kernel  size of
2147483647 KB

Backing off to just 2 terabytes worked ala the following:
 'lvcreate -L2T -nLV1 VG1' 
 lvcreate -- doing automatic backup of "VG1"
 lvcreate -- logical volume "/dev/VG1/LV1" successfully created



Version-Release number of selected component (if applicable):
lvm-1.0.3-12, kernel version 2.4.20-18.9smp

How reproducible:
Always

Steps to Reproduce:
1. steps to reproduce stated in above description
2.
3.
    

Additional info:
Comment 1 Stephen Tweedie 2003-06-10 16:24:17 EDT
The Linux block device layer is limited to 2TB in the 2.4 kernel.  This is not a
bug, simply an upper limit that all block devices share, be they physical or
logical.
Comment 2 lnelson 2003-06-11 10:32:55 EDT
Thank you very much for the quick response.  

However, I suppose I should have added to my initial post:
"If this is not a bug, then when will RedHat Linux support logical voumes greater than
2 terabytes?"  This is critical as we are migrating from older legacy systems that DO
support >2TB filesystems and RedHat's documentation on LVM implies that >2TB logical 
filesystems are possible (since >2TB volume groups are clearly possible).  So, at the 
very least, I'm re-opening this to point out a bug in the documentation.  The docs need
to indicate that there is a 2TB limit.  We very much need to know if/when the greater
capacity will be supported.  Thank you
Comment 3 Stephen Tweedie 2003-06-11 11:28:08 EDT
Individual block devices larger than 2TB will not be supported until the 2.6
kernel is ready for production use.  If you could let me know just which
documentation you would like this limit mentioned in, I'll pass that request on.
Comment 4 lnelson 2003-06-11 11:43:04 EDT
> Individual block devices larger than 2TB will not be supported until the 2.6
> kernel is ready for production use.  

Thank you!  This is most helpful for planning purposes.

> If you could let me know just which documentation you would like this limit 
> mentioned in, I'll pass that request on.

Certainly, and thank you!
I would think at the very least, a mention of the 2TB limit could be placed early on 
in the lvm man page.  A good place looks to be right after the last sentence of the
first paragraph, where it mentions the size of a logical volume is in multiples of
physical extents.

Also in vgcreate and lvcreate man pages.  Those 3 man pages, at least, will have been
read in all likelihood by anyone attempting to create logical volumes.  It could be as
simple as "Note: the current linux kernel, through 2.5, does not support logical volumes
past 2 terabytes."  Or something like that.

Again, many thanks
Comment 6 Heinz Mauelshagen 2005-01-28 09:26:21 EST
This is documented in lvm.8

Note You need to log in before you can comment on or make changes to this bug.