Bug 971280 - "{"exit_code"=>nil, "field"=>nil, "severity"=>"info", "text"=>"Application 'zendtest' found"}" is shown when restart app
"{"exit_code"=>nil, "field"=>nil, "severity"=>"info", "text"=>"Application 'z...
Status: CLOSED CURRENTRELEASE
Product: OpenShift Online
Classification: Red Hat
Component: Website (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Jordan Liggitt
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-06 03:49 EDT by Wei Sun
Modified: 2015-05-14 21:27 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-24 10:51:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
restartapp (90.68 KB, image/png)
2013-06-06 04:52 EDT, Wei Sun
no flags Details

  None (edit)
Description Wei Sun 2013-06-06 03:49:27 EDT
Description of problem:
When restart the app,some messages will be shown:
{"exit_code"=>nil, "field"=>nil, "severity"=>"info", "text"=>"Application 'zendtest' found"}
please refer to attachment

Version-Release number of selected component (if applicable):
devenv_3324

How reproducible:
Always

Steps to Reproduce:
1.Create an application
2.Restart the app
3.

Actual results:
"{"exit_code"=>nil, "field"=>nil, "severity"=>"info", "text"=>"Application 'zendtest' found"}" is shown

Expected results:
Don't have this message

Additional info:
Comment 1 Wei Sun 2013-06-06 04:52:48 EDT
Created attachment 757554 [details]
restartapp
Comment 2 Jordan Liggitt 2013-06-06 10:28:55 EDT
same issue exists when deleting an app alias
Comment 3 Clayton Coleman 2013-06-07 12:14:59 EDT
This is due to the 1.5 change to return 200 content on deletes.  This seems wrong though - as in either the broker is returning poorly formatted JSON, or a bad message.
Comment 4 Jordan Liggitt 2013-06-07 13:00:29 EDT
The broker is fine. We're reading the messages off the application object, which isn't getting updated from the remove_alias or restart! methods
Comment 5 Jordan Liggitt 2013-06-13 16:10:45 EDT
Marked as [merge] in https://github.com/openshift/origin-server/pull/2775
Comment 6 openshift-github-bot 2013-06-13 20:29:55 EDT
Commit pushed to master at https://github.com/openshift/origin-server

https://github.com/openshift/origin-server/commit/49862a32804b5645f95bc12419d5f2f88e8f59e7
Fix bug 971280 - make app restart message correct

Update restart controller test
Comment 7 Yujie Zhang 2013-06-14 02:22:10 EDT
Tested on devenv_3360, the return message after restarting app is correct now, so verify this bug, thanks.

Note You need to log in before you can comment on or make changes to this bug.