Bug 971284 - EJB2 Entities CMT handling fall back to default for Home methods even if a 'all method' element is added to the deployment descriptor
Summary: EJB2 Entities CMT handling fall back to default for Home methods even if a 'a...
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: EJB (Show other bugs)
(Show other bugs)
Version: 6.1.0
Hardware: Unspecified Unspecified
unspecified
medium
Target Milestone: ---
: EAP 6.4.0
Assignee: Dominik Pospisil
QA Contact: Jan Martiska
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-06-06 08:02 UTC by wfink
Modified: 2018-12-01 14:36 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-03-20 09:53:23 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description wfink 2013-06-06 08:02:10 UTC
Description of problem:
If the following element is added to the DS
   <container-transaction >
      <method >
         <ejb-name>SimpleBMPEntity</ejb-name>
          <method-name>*</method-name>
       </method>
       <trans-attribute>RequiresNew</trans-attribute>
    </container-transaction>

The expectation is that ALL methods are executed with a new Tx in CMT.
In opposite to former versions, where this is true, here the Tx fall back to the default which is 'Required'.

This will have unexpected results during Migration.

A possible workaround is to add a extra container-transaction element and specify the <method-intf>LocalHome</method-intf> (RemoteHome should be avoided for different reasons).
But this will be a huge effort if the application contains a big number of such Entities.

Comment 3 Dimitris Andreadis 2013-10-24 18:27:59 UTC
Assigning jpai@redhat.com EJB issues to david.lloyd@redhat.com. Please re-assign to Cheng or others as needed.

Comment 4 Dominik Pospisil 2015-03-20 09:53:23 UTC
Closing as I was not able to reproduce the issue with 6.4.x branch.

Testcase showing <method-name>*</method-name> works for both instance and local home interfaces in CMP as well as BMP beans:

https://github.com/dpospisil/jboss-eap/commit/3ab7a6acbc012ad5a25c0e3eccb3ccfe59031877


Note You need to log in before you can comment on or make changes to this bug.