Bug 97129 - RPM seg faults
RPM seg faults
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: rpm (Show other bugs)
2.1
All Linux
high Severity medium
: ---
: ---
Assigned To: Jeff Johnson
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-06-10 14:12 EDT by Bryan Che
Modified: 2007-11-30 17:06 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-17 23:08:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bryan Che 2003-06-10 14:12:14 EDT
I up2dated completely an AS 2.1 box yesterday, and now I can't install new rpm's
or rebuild the rpm database.  I always get segmentation faults.  For example: 


rpm -ivh VMware-workstation-4.0.0-4460.i386.rpm
Preparing...                Segmentation fault

rpmdb --rebuilddb
*** dbiUpdateRecord: uh is NULL
Segmentation fault

Before the up2date, rpm worked fine.

I'll e-mail a copy of my /var/lib/rpm db.
Comment 1 Jeff Johnson 2003-06-10 14:46:21 EDT
FIxed.
Comment 2 Bryan Che 2003-06-10 16:24:13 EDT
After installing the fix, I can install rpm's again.  But, running up2date gives
me the following error:

up2date -u
Error communicating with server.  The message was:

Error Message:
    Your account does not have access to any channels matching
(release='8.0.93', arch='i686-redhat-linux')
Error Class Code: 19
Error Class Info:
     Architecture and OS version combination is not supported.
     If you have a registration number, please register with it
     first at http://www.redhat.com/now and then try again.
Explanation:
     An error has occurred while processing your request. If this problem
     persists please enter a bug report at bugzilla.redhat.com.
     If you choose to submit the bug report, please be sure to include
     details of what you were trying to do when this error occurred and
     details on how to reproduce this problem.
Comment 3 Bryan Che 2003-06-11 09:49:19 EDT
I think that this bug may be due to the Packages file that Jeff sent me.  I did
a search through that file, and I see a string in it that reads,
"redhat-release^@8.0.93^"
Comment 4 Bryan Che 2003-06-11 09:58:38 EDT
I also wonder if the rpm Package file lists all the right rpm's.  For example:

/root/>rpm -q make
make-3.79.1-17
/root/>which make
/usr/bin/which: no make in
(/opt/resin/2.1.8/bin:/opt/apps/oracle/product/9.2.0/bin:/opt/apps/oracle/product/9.2.0/ctx/lib:/opt/apps/oracle/product/9.2.0/bin:/opt/ap\
ps/oracle/product/9.2.0/ctx/lib:/usr/kerberos/sbin:/usr/kerberos/bin:/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin:/usr/X11R6/bin:/usr/java/jdk1.3.1_0\
8/bin:/root/bin:/usr/java/jdk1.3.1_08/bin)
Comment 5 Bryan Che 2003-06-11 10:09:14 EDT
reassigning to jeff, as this doesn't seem to be an rhn but an rpm problem
Comment 6 Adrian Likins 2003-06-11 15:29:10 EDT
seems fixed now, at least the up2date error, closing
Comment 7 Bryan Che 2003-06-11 16:49:24 EDT
Reopened bug while waiting for fixed AS 2.1 rpm Packages db
Comment 8 Jeff Johnson 2005-01-17 23:08:19 EST
WONTFIX in the sense that no AS 2.1 change for rpm is currently planned.

Note You need to log in before you can comment on or make changes to this bug.