Bug 971299 - ovirt-node-upgrade : remove /data/tmpiso_* during cleanup
ovirt-node-upgrade : remove /data/tmpiso_* during cleanup
Status: CLOSED CURRENTRELEASE
Product: oVirt
Classification: Community
Component: ovirt-node (Show other bugs)
unspecified
Unspecified Unspecified
low Severity low
: ---
: 3.4.0
Assigned To: Joey Boggs
bugs@ovirt.org
node
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-06 04:51 EDT by haiyang,dong
Modified: 2014-03-31 08:28 EDT (History)
13 users (show)

See Also:
Fixed In Version: ovirt-3.4.0-beta1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-31 08:28:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description haiyang,dong 2013-06-06 04:51:55 EDT
Description of problem:
Enhance the function "_cleanup()" for ovirt-node-upgrade tools to 
remove /data/tmpiso_* during cleanup after execute 
"cat ovirt-node-iso-3.0.0-0.999.999.20130603183100git6c4298c.811.fc18.iso |ssh admin@10.66.9.35
 'ovirt-node-upgrade --iso - --reboot 10'"
to upgrade ovirt-node upstream successfully online

Version-Release number of selected component (if applicable):
ovirt-node-iso-3.0.0-0.999.999.20130603183100git6c4298c.811.fc18.iso

How reproducible:
100%


 
Steps to Reproduce:


Actual result:

                                                  
Expect result:


Additional info:
Comment 1 Mike Burns 2013-06-06 08:20:05 EDT
I think a patch for this is posted already -- Joey?
Comment 2 haiyang,dong 2013-06-06 22:15:55 EDT
http://gerrit.ovirt.org/#/c/15404/

remove /data/tmpiso_* during cleanup
Comment 3 haiyang,dong 2013-06-07 05:55:11 EDT
sorry, please review patch http://gerrit.ovirt.org/#/c/15436/,
and ignore comment 2's patch
Comment 4 Sandro Bonazzola 2014-01-27 08:51:05 EST
This should be fixed in oVirt 3.4.0 beta1 build
Comment 5 haiyang,dong 2014-03-03 01:50:12 EST
Test version:
ovirt-node-iso-3.0.4-1.0.201401291204.el6.iso

It has enhanced the function "_cleanup()" for ovirt-node-upgrade tools to 
remove /data/tmpiso_* during cleanup after execute 
"ovirt-node-upgrade --iso ovirt-node-iso-3.0.4-1.0.201401291204.el6.iso --reboot 10'"
to upgrade ovirt-node upstream successfully online

so this bug has been fixed, change the status into "verified".
Comment 6 Sandro Bonazzola 2014-03-31 08:28:02 EDT
this is an automated message: moving to Closed CURRENT RELEASE since oVirt 3.4.0 has been released

Note You need to log in before you can comment on or make changes to this bug.