Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 971307 - [abrt] yum-3.4.3-91.fc19: igroups.py:92:_read_pkg_grps:ValueError: invalid literal for int() with base 10: ''
[abrt] yum-3.4.3-91.fc19: igroups.py:92:_read_pkg_grps:ValueError: invalid li...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: James Antill
Fedora Extras Quality Assurance
abrt_hash:330158dc6063065f73d07e86059...
:
: 1047409 1070143 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-06 05:06 EDT by Ladislav Jozsa
Modified: 2014-07-09 11:23 EDT (History)
9 users (show)

See Also:
Fixed In Version: yum-3.4.3-148.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-09 22:57:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (1.40 KB, text/plain)
2013-06-06 05:06 EDT, Ladislav Jozsa
no flags Details
File: core_backtrace (873 bytes, text/plain)
2013-06-06 05:06 EDT, Ladislav Jozsa
no flags Details
File: environ (2.13 KB, text/plain)
2013-06-06 05:06 EDT, Ladislav Jozsa
no flags Details

  None (edit)
Description Ladislav Jozsa 2013-06-06 05:06:44 EDT
Description of problem:


Version-Release number of selected component:
yum-3.4.3-91.fc19

Additional info:
reporter:       libreport-2.1.4
cmdline:        /usr/bin/python /bin/yum install gparted
executable:     /bin/yum
kernel:         3.9.4-300.fc19.x86_64
runlevel:       N 5
uid:            0

Truncated backtrace:
igroups.py:92:_read_pkg_grps:ValueError: invalid literal for int() with base 10: ''

Traceback (most recent call last):
  File "/bin/yum", line 29, in <module>
    yummain.user_main(sys.argv[1:], exit_code=True)
  File "/usr/share/yum-cli/yummain.py", line 316, in user_main
    errcode = main(args)
  File "/usr/share/yum-cli/yummain.py", line 219, in main
    return_code = base.doTransaction()
  File "/usr/share/yum-cli/cli.py", line 713, in doTransaction
    resultobject = self.runTransaction(cb=cb)
  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 1801, in runTransaction
    self.igroups.save()
  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 1062, in <lambda>
    igroups = property(fget=lambda self: self._getIGroups(),
  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 1022, in _getIGroups
    self._igroups = yum.igroups.InstalledGroups(db_path=pdb_path)
  File "/usr/lib/python2.7/site-packages/yum/igroups.py", line 80, in __init__
    self._read_pkg_grps(db_path)
  File "/usr/lib/python2.7/site-packages/yum/igroups.py", line 92, in _read_pkg_grps
    ver = int(_read_str(fo))
ValueError: invalid literal for int() with base 10: ''

Local variables in innermost frame:
_read_str: <function _read_str at 0x2d14140>
db_path: '/var/lib/yum/groups'
self: <yum.igroups.InstalledGroups object at 0x2bf1f90>
fo: <open file '/var/lib/yum/groups/installed', mode 'r' at 0x2f2ded0>
Comment 1 Ladislav Jozsa 2013-06-06 05:06:49 EDT
Created attachment 757568 [details]
File: backtrace
Comment 2 Ladislav Jozsa 2013-06-06 05:06:54 EDT
Created attachment 757569 [details]
File: core_backtrace
Comment 3 Ladislav Jozsa 2013-06-06 05:06:59 EDT
Created attachment 757570 [details]
File: environ
Comment 4 Jan Zeleny 2013-06-10 04:13:46 EDT
This seems to be loosely related to the recent changes in yum groups. James, could you please take a look at it?
Comment 5 Valentina Mukhamedzhanova 2014-03-03 10:29:41 EST
*** Bug 1070143 has been marked as a duplicate of this bug. ***
Comment 6 Valentina Mukhamedzhanova 2014-03-03 10:29:43 EST
*** Bug 1047409 has been marked as a duplicate of this bug. ***
Comment 7 Fedora Update System 2014-05-22 09:10:21 EDT
yum-3.4.3-148.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/yum-3.4.3-148.fc20
Comment 8 Fedora Update System 2014-05-23 14:54:54 EDT
Package yum-3.4.3-148.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing yum-3.4.3-148.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-6603/yum-3.4.3-148.fc20
then log in and leave karma (feedback).
Comment 9 Mykola Dvornik 2014-05-23 15:08:36 EDT
The issue is still there
Comment 10 Valentina Mukhamedzhanova 2014-05-26 09:08:50 EDT
Hi Mykola, do you mean the issue is still there in Fedora 19? Because the update has been issued only for Fedora 20 so far.
Comment 11 Fedora Update System 2014-06-09 22:57:23 EDT
yum-3.4.3-148.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Mykola Dvornik 2014-06-16 08:01:59 EDT
I mean Fedora 20. The bug is still there.
Comment 13 Fedora Update System 2014-07-09 11:23:00 EDT
yum-3.4.3-152.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/yum-3.4.3-152.fc19

Note You need to log in before you can comment on or make changes to this bug.