Bug 971310 - Unhandled Python exception in dumpStorageTable.pyc when running sosreport on RHSC node
Unhandled Python exception in dumpStorageTable.pyc when running sosreport on ...
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: vdsm (Show other bugs)
2.1
x86_64 Linux
high Severity high
: ---
: ---
Assigned To: Aravinda VK
Prasanth
:
Depends On: 961816
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-06 05:12 EDT by Sahina Bose
Modified: 2013-09-15 23:28 EDT (History)
12 users (show)

See Also:
Fixed In Version: bb6
Doc Type: Bug Fix
Doc Text:
Previously if the sosreport tool was run on a Red Hat Storage node, it would fail if the storage pool list was empty. Now the fix enables the sosreport tool to handle an empty pool list.
Story Points: ---
Clone Of: 961816
Environment:
Last Closed: 2013-09-15 23:28:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 14886 None None None Never

  None (edit)
Comment 2 Aravinda VK 2013-06-27 03:51:55 EDT
Resubmitted the upstream patch(Under review)
http://gerrit.ovirt.org/#/c/14886/

Submitted downstream patch
https://code.engineering.redhat.com/gerrit/#/c/9405/
Comment 3 Sahina Bose 2013-07-24 07:46:14 EDT
Available in latest RHS 2.1 ISO
Comment 4 Dustin Tsang 2013-08-09 13:54:53 EDT
sosreport && python /usr/share/vdsm/dumpStorageTable.py were successfully run on 
a rhs 2.1 20130731 node added to rhsc bb8 server.
Comment 5 Pavithra 2013-08-27 02:31:04 EDT
Kindly verify if the edited doc text is technically correct and sign off
Comment 7 errata-xmlrpc 2013-09-15 23:28:52 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html

Note You need to log in before you can comment on or make changes to this bug.