Bug 971318 - PRD33 - super vdsm as a service
Summary: PRD33 - super vdsm as a service
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: vdsm (Show other bugs)
(Show other bugs)
Version: 3.3.0
Hardware: Unspecified Unspecified
unspecified
unspecified
Target Milestone: ---
: 3.3.0
Assignee: Yaniv Bronhaim
QA Contact: Pavel Stehlik
URL:
Whiteboard: infra
Keywords: CodeChange, FutureFeature
Depends On:
Blocks: 1019470
TreeView+ depends on / blocked
 
Reported: 2013-06-06 09:19 UTC by Itamar Heim
Modified: 2016-02-10 19:00 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Previously supervdsm, which is responsible for all privileged options, was managed by the unprivileged vdsm process. This led to races between new and old instances of the processes. Supervdsm now runs as a service external to vdsm, additionally updates have been made to handle crashes and re-establish communication between vdsm and supervdsm after failures.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-21 16:08:47 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:0040 normal SHIPPED_LIVE vdsm bug fix and enhancement update 2014-01-21 20:26:21 UTC
oVirt gerrit 11051 None None None Never

Description Itamar Heim 2013-06-06 09:19:56 UTC

Comment 1 Aharon Canan 2013-07-09 09:33:07 UTC
http://www.ovirt.org/Features/Supervdsm_service

Comment 5 Aharon Canan 2013-08-11 14:34:57 UTC
Execution results

https://tcms.engineering.redhat.com/run/74334/

Comment 7 Charlie 2013-11-28 00:32:13 UTC
This bug is currently attached to errata RHBA-2013:15291. If this change is not to be documented in the text for this errata please either remove it from the errata, set the requires_doc_text flag to 
minus (-), or leave a "Doc Text" value of "--no tech note required" if you do not have permission to alter the flag.

Otherwise to aid in the development of relevant and accurate release documentation, please fill out the "Doc Text" field above with these four (4) pieces of information:

* Cause: What actions or circumstances cause this bug to present.
* Consequence: What happens when the bug presents.
* Fix: What was done to fix the bug.
* Result: What now happens when the actions or circumstances above occur. (NB: this is not the same as 'the bug doesn't present anymore')

Once filled out, please set the "Doc Type" field to the appropriate value for the type of change made and submit your edits to the bug.

For further details on the Cause, Consequence, Fix, Result format please refer to:

https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes 

Thanks in advance.

Comment 8 errata-xmlrpc 2014-01-21 16:08:47 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0040.html


Note You need to log in before you can comment on or make changes to this bug.