Bug 971356 - [upgrade] Jenkins migration is leaving oo-accept-node with an error: "Gear has a websocket framework cartridge but no websocket configuration" after migrate
[upgrade] Jenkins migration is leaving oo-accept-node with an error: "Gear ha...
Status: CLOSED CURRENTRELEASE
Product: OpenShift Container Platform
Classification: Red Hat
Component: Pod (Show other bugs)
1.2.0
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Brenton Leanhardt
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-06 06:54 EDT by Johnny Liu
Modified: 2017-03-08 12 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-28 11:47:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Johnny Liu 2013-06-06 06:54:40 EDT
Description of problem:
Jenkins migration is leaving oo-accept-node with an error: "Gear has a websocket framework cartridge but no websocket configuration"

Version-Release number of selected component (if applicable):
1.2/2013-06-05.9

How reproducible:
Always

Steps to Reproduce:
1. Setup ose-1.1.3 env
2. Create a jenkins app
3. Following http://etherpad.corp.redhat.com/OSE-1-2-upgrade-notes to do upgrade testing
4. After upgrade, run oo-accept-node

Actual results:
# oo-accept-node
FAIL: Gear has a websocket framework cartridge but no websocket configuration: 4a105df2e6e74e5e9de144b40a7927f6


Expected results:
There should be no such error.

Additional info:
Comment 2 Luke Meyer 2013-06-06 16:27:40 EDT
Good catch. I noticed this and was digging through the oo-accept-node logic to try to figure why it was detecting that. It turns out, it was looking at the v1 cart and finding "--websocket" in the proxy hook. However, according to dmcphers that logic should be v1/v2-aware and so this shouldn't be happening. So it's either faulty oo-accept-node logic or (more likely) something about our migrated gears is misleading it.

It appears to be ONLY Jenkins BTW.
Comment 3 Rob Millner 2013-06-06 17:47:31 EDT
Kenny and I ran into it as well as an issue where the DNS variable had capitals in it after migration.

Pull requests for master:
https://github.com/openshift/origin-server/pull/2780

Pull requests for stage:
https://github.com/openshift/origin-server/pull/2781
Comment 4 Gaoyun Pei 2013-06-14 04:14:27 EDT
Verify this against puddle:
http://buildvm-devops.usersys.redhat.com/puddle/build/OpenShiftEnterprise/1.2/2013-06-13.1/

Setup an OSE env using puddle 1.1.z/2013-06-11.2. Create a series of applications including jenkins-1.4 app. 
Then update this env to puddle 1.2/2013-06-13.1, run oo-accept-node.

[root@node ~]# oo-accept-node -v
INFO: using default accept-node extensions
INFO: loading node configuration file /etc/openshift/node.conf
INFO: loading resource limit file /etc/openshift/resource_limits.conf
INFO: checking node public hostname resolution
INFO: checking selinux status
INFO: checking selinux openshift-origin policy
INFO: checking selinux booleans
INFO: checking package list
INFO: checking services
INFO: checking kernel semaphores >= 512
INFO: checking cgroups configuration
INFO: checking cgroups processes
INFO: checking filesystem quotas
INFO: checking quota db file selinux label
INFO: checking 27 user accounts
INFO: checking application dirs
INFO: checking system httpd configs
PASS

No errors throw out, so verify this bug.
Comment 5 Luke Meyer 2013-06-28 11:47:50 EDT
Closing all bugs introduced, fixed, and verified during 1.2 release work (thus never shipped).

Note You need to log in before you can comment on or make changes to this bug.