Bug 971366 - SELinux is preventing /usr/sbin/mcelog from 'unlink' accesses on the sock_file mcelog-client.
SELinux is preventing /usr/sbin/mcelog from 'unlink' accesses on the sock_fil...
Status: CLOSED DUPLICATE of bug 971365
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:6362f6ec1b2ff43b35fdc53ee17...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-06 07:13 EDT by Frank Murphy
Modified: 2013-06-06 07:57 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-06 07:57:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Frank Murphy 2013-06-06 07:13:38 EDT
Description of problem:
As per bz #971365
SELinux is preventing /usr/sbin/mcelog from 'unlink' accesses on the sock_file mcelog-client.

*****  Plugin catchall (100. confidence) suggests  ***************************

If you believe that mcelog should be allowed unlink access on the mcelog-client sock_file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep mcelog /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:mcelog_t:s0
Target Context                unconfined_u:object_r:var_run_t:s0
Target Objects                mcelog-client [ sock_file ]
Source                        mcelog
Source Path                   /usr/sbin/mcelog
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           mcelog-1.0-0.6.6e4e2a00.fc18.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.11.1-97.fc18.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 3.9.4-200.fc18.x86_64 #1 SMP Fri
                              May 24 20:10:49 UTC 2013 x86_64 x86_64
Alert Count                   2
First Seen                    2013-06-06 12:08:00 IST
Last Seen                     2013-06-06 12:08:00 IST
Local ID                      59a4c2c5-fa6d-49b3-9b28-298fbcf075b6

Raw Audit Messages
type=AVC msg=audit(1370516880.740:788): avc:  denied  { unlink } for  pid=8415 comm="mcelog" name="mcelog-client" dev="tmpfs" ino=1560272 scontext=system_u:system_r:mcelog_t:s0 tcontext=unconfined_u:object_r:var_run_t:s0 tclass=sock_file


type=SYSCALL msg=audit(1370516880.740:788): arch=x86_64 syscall=unlink success=no exit=EACCES a0=17d35b0 a1=7fff01fa5480 a2=0 a3=8 items=0 ppid=1 pid=8415 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 ses=4294967295 tty=(none) comm=mcelog exe=/usr/sbin/mcelog subj=system_u:system_r:mcelog_t:s0 key=(null)

Hash: mcelog,mcelog_t,var_run_t,sock_file,unlink

audit2allow

#============= mcelog_t ==============
allow mcelog_t var_run_t:sock_file unlink;

audit2allow -R
require {
	type mcelog_t;
}

#============= mcelog_t ==============
files_delete_all_pids(mcelog_t)


Additional info:
reporter:       libreport-2.1.4.24.g872f
hashmarkername: setroubleshoot
kernel:         3.9.4-200.fc18.x86_64
type:           libreport
Comment 1 Miroslav Grepl 2013-06-06 07:57:23 EDT

*** This bug has been marked as a duplicate of bug 971365 ***

Note You need to log in before you can comment on or make changes to this bug.