Bug 971408 - virtlockd, init script and kill signals
virtlockd, init script and kill signals
Status: CLOSED UPSTREAM
Product: Virtualization Tools
Classification: Community
Component: libvirt (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Libvirt Maintainers
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-06 08:53 EDT by Franky Van Liedekerke
Modified: 2016-04-09 19:43 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-09 19:43:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
virtlock diff (1.11 KB, patch)
2013-06-06 08:53 EDT, Franky Van Liedekerke
no flags Details | Diff

  None (edit)
Description Franky Van Liedekerke 2013-06-06 08:53:30 EDT
Created attachment 757679 [details]
virtlock diff

Description of problem:

1) according to the doc, virtlockd uses SIGUSR1 to dump its state and then re-execs itself. Now I tried it and this seems to fail because virtlockd is being launched without a full path (when using the init script), thus re-exec fails with the error:

error : virLockDaemonPreExecRestart:1092 : Unable to restart self: No
such file or directory

2) since virtlockd needs to be started before libvirtd, the startup sequence number for virtlockd should be 96, not 97 for init levels 3,5

3) virtlockd needs /etc/libvirt/qemu-lockd.conf as default conf file

Version-Release number of selected component (if applicable):
1.04, but still in 1.0.6 as well.


Additional info:
See attachment for a unified diff fix. Two files change: src/locking/virtlockd.init.in and src/locking/virtlockd.sysconf . The diff is against 1.0.4, but is still valid for 1.0.6 as wel.
Comment 1 Cole Robinson 2016-04-09 19:43:17 EDT
Sorry this never received a response. For future reference patches should go to the mailing list which gets much better attention.

The config file bit doesn't seem to be required... from my inspection of the code it looks like the daemon knows to look for that file if a config isn't specific, and I think it's always been like that

The init level bit was fixed by:

commit 6dc0e4f1718743a95050081fc06fa0fe06af281c
Author: Martin Kletzander <mkletzan@redhat.com>
Date:   Thu Jan 7 09:50:26 2016 +0100

    Fix LSB requirements in service script and sync them

Note You need to log in before you can comment on or make changes to this bug.