Bug 971417 - Accented characters not handled correctly
Accented characters not handled correctly
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: system-config-printer (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-06 09:06 EDT by Emmanuel Pacaud
Modified: 2013-06-13 02:36 EDT (History)
3 users (show)

See Also:
Fixed In Version: system-config-printer-1.4.1-6.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-13 02:36:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Emmanuel Pacaud 2013-06-06 09:06:26 EDT
I'm using a UTF-8 french locale.

Until now, I have always successfully used accented characters for printer location. In fedora 19, system-config-printer doesn't like these characters, and emits wanings on the console output:


Traceback (most recent call last):
  File "/usr/share/system-config-printer/printerproperties.py", line 691, in on_printer_changed
    old_value = old_value.encode (locale.getpreferredencoding ())
UnicodeEncodeError: 'ascii' codec can't encode character u'\xe2' in position 1: ordinal not in range(128)
Unknown value for media-col: (unknown IPP value tag 0x34)
Comment 1 Tim Waugh 2013-06-06 11:40:30 EDT
What does 'locale' say?
Comment 2 Emmanuel Pacaud 2013-06-06 11:42:52 EDT
locale
LANG=fr_FR.utf8
LC_CTYPE="fr_FR.utf8"
LC_NUMERIC="fr_FR.utf8"
LC_TIME="fr_FR.utf8"
LC_COLLATE="fr_FR.utf8"
LC_MONETARY="fr_FR.utf8"
LC_MESSAGES="fr_FR.utf8"
LC_PAPER="fr_FR.utf8"
LC_NAME="fr_FR.utf8"
LC_ADDRESS="fr_FR.utf8"
LC_TELEPHONE="fr_FR.utf8"
LC_MEASUREMENT="fr_FR.utf8"
LC_IDENTIFICATION="fr_FR.utf8"
LC_ALL=

Here's an example of accented location string:

"Bâtiment rond - 1er étage - Cafétéria"
Comment 3 Emmanuel Pacaud 2013-06-06 11:49:50 EDT
Sorry, in fact the issue happens when I launch system-config-printer from root, with the C locale.

LANG=C
LC_CTYPE="C"
LC_NUMERIC="C"
LC_TIME="C"
LC_COLLATE="C"
LC_MONETARY="C"
LC_MESSAGES="C"
LC_PAPER="C"
LC_NAME="C"
LC_ADDRESS="C"
LC_TELEPHONE="C"
LC_MEASUREMENT="C"
LC_IDENTIFICATION="C"
LC_ALL=
Comment 4 Tim Waugh 2013-06-07 07:38:58 EDT
I think this should be addressed in system-config-printer-1.4.1-5.fc19.  I'll make a test update shortly... please test it and let me know.
Comment 5 Fedora Update System 2013-06-07 12:29:31 EDT
system-config-printer-1.4.1-6.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/system-config-printer-1.4.1-6.fc19
Comment 6 Fedora Update System 2013-06-07 22:57:17 EDT
Package system-config-printer-1.4.1-6.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing system-config-printer-1.4.1-6.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-10351/system-config-printer-1.4.1-6.fc19
then log in and leave karma (feedback).
Comment 7 Emmanuel Pacaud 2013-06-10 04:14:22 EDT
I looks like 1.4.1-6 actually fixed this issue.

Thanks.
Comment 8 Tim Waugh 2013-06-10 05:03:10 EDT
Great, thanks for testing.
Comment 9 Fedora Update System 2013-06-13 02:36:51 EDT
system-config-printer-1.4.1-6.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.