Bug 971437 - [mesa-dri-drivers] libGL error: failed to load driver: i965 (T530, Intel GT2)
[mesa-dri-drivers] libGL error: failed to load driver: i965 (T530, Intel GT2)
Status: CLOSED DUPLICATE of bug 969704
Product: Fedora
Classification: Fedora
Component: mesa (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-06 10:00 EDT by Jan Pokorný
Modified: 2013-06-13 11:28 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-13 11:28:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Pokorný 2013-06-06 10:00:01 EDT
(disclaimer: a newbie regarding problems with graphics)

Wanted to try extremetuxracer to verify graphics is OK on my T530
with "Integrated Graphics Chipset: Intel(R) Ivybridge Mobile (GT2)"
in Fedora 18.

It crashed, so I started a brief inspection:

$ LIBGL_DEBUG=verbose glxinfo | grep direct
> libGL: OpenDriver: trying /usr/lib64/dri/i965_dri.so
> libGL error: failed to open drm device: Permission denied
> libGL error: failed to load driver: i965
> libGL: OpenDriver: trying /usr/lib64/dri/swrast_dri.so
> libGL: Can't open configuration file /home/jpokorny/.drirc: No such file or directory.
> libGL: Can't open configuration file /home/jpokorny/.drirc: No such file or directory.
> libGL: Can't open configuration file /home/jpokorny/.drirc: No such file or directory.
> libGL: Can't open configuration file /home/jpokorny/.drirc: No such file or directory.
> libGL: Can't open configuration file /home/jpokorny/.drirc: No such file or directory.
> libGL: Can't open configuration file /home/jpokorny/.drirc: No such file or directory.
> libGL: Can't open configuration file /home/jpokorny/.drirc: No such file or directory.
> libGL: Can't open configuration file /home/jpokorny/.drirc: No such file or directory.
> direct rendering: Yes

$ rpm -q mesa-dri-drivers
> mesa-dri-drivers-9.1-3.fc18.x86_64

$ repoquery -f /usr/lib64/dri/i965_dri.so
> mesa-dri-drivers-0:9.2-0.7.20130528.fc18.x86_64
> mesa-dri-drivers-0:9.0.1-1.fc18.x86_64

$ su -

# yum install -y mesa-dri-drivers-0:9.2-0.7.20130528.fc18.x86_64  # from updates
# exit

$ LIBGL_DEBUG=verbose glxinfo | grep direct
> libGL: OpenDriver: trying /usr/lib64/dri/i965_dri.so
> libGL error: dlopen /usr/lib64/dri/i965_dri.so failed (/lib64/libdricore9.2.0.so.1: undefined symbol: _glapi_tls_Context)
> libGL error: unable to load driver: i965_dri.so
> libGL error: driver pointer missing
> libGL error: failed to load driver: i965
> libGL: OpenDriver: trying /usr/lib64/dri/swrast_dri.so
> libGL error: dlopen /usr/lib64/dri/swrast_dri.so failed (/usr/lib64/dri/swrast_dri.so: undefined symbol: _glapi_tls_Dispatch)
> libGL error: unable to load driver: swrast_dri.so
> libGL error: failed to load driver: swrast
> direct rendering: No (If you want to find out why, try setting LIBGL_DEBUG=verbose)


I've found thread [1] that could be related.
Will be more than happy to provided any missing information bits.
Ultimate goal is to make the mentioned graphics work properly for 3D.


[1] http://lists.x.org/archives/xorg/2010-May/050119.html
Comment 1 Jan Pokorný 2013-06-07 12:54:59 EDT
After restart and yum update [*] (without additional restart),
everything seems to be OK:

$ LIBGL_DEBUG=verbose glxinfo | grep direct
libGL: OpenDriver: trying /usr/lib64/dri/tls/i965_dri.so
libGL: OpenDriver: trying /usr/lib64/dri/i965_dri.so
libGL: Can't open configuration file /home/jpokorny/.drirc: No such file or directory.
libGL: Can't open configuration file /home/jpokorny/.drirc: No such file or directory.
direct rendering: Yes
libGL: Can't open configuration file /home/jpokorny/.drirc: No such file or directory.
You have new mail in /var/spool/mail/jpokorny


[*]
in addition to mesa-{filesystem,dri-drivers,libxatracker}-9.2-0.7.20130528
and llvm-libs-3.3-0.4.rc2 pulled in when updating just mesa-dri-drivers
as mentioned, following mesa packages were update with this global update:

  - mesa-libglapi-9.2-0.7.20130528.fc18.x86_64
  - mesa-libGL-9.2-0.7.20130528.fc18.x86_64
  - mesa-libgbm-9.2-0.7.20130528.fc18.x86_64
  - mesa-libEGL-9.2-0.7.20130528.fc18.x86_64
  - mesa-libGL-devel-9.2-0.7.20130528.fc18.x86_64
  - mesa-libEGL-devel-9.2-0.7.20130528.fc18.x86_64

There is a little space of possibility that these should have been required
as well by mesa-dri-drivers, but could be a problem of not performing
a restart (of system or of X) first.

My vote is to close this bug (and will do if there is no feedback in
a few weeks).
Comment 2 Alexey Chentsov 2013-06-13 11:13:42 EDT
I had the same problem after installing clang++. Which ultimately led to updating of mesa-dri-drivers. Depending on setting user can experience some or all of the following:
1. gnome-control-center unavailability (crush)
2. no gdm login prompt 
3. unable to unlock the screen
4. gnome loads in fallback mode

Problem here is that 1) updated mesa has glx-tls compilation option enabled while previous didn't, 2) mesa-dri-drivers has implicit dependency on libglapi that is not getting updated automatically.

Individual solution here is to update libglapi.so
$ sudo yum update mesa-libglapi

Global solution is to add to mesa-dri-drivers dependency on mesa-libglapi.

This bug is similar to https://bugzilla.redhat.com/show_bug.cgi?id=969704
Comment 3 Jan Pokorný 2013-06-13 11:28:39 EDT
re [comment 2]:

Thanks Mr. Chentsov for a better analysis and for discovering the link
to the other bug (I tried to find if there is an existing report prior
to filing this one, but still missed it).

> Global solution is to add to mesa-dri-drivers dependency on mesa-libglapi.

This is what I thought ("possibility that these should have been required
as well by mesa-dri-drivers") but hadn't been willing to dive even more.

Anyway, I am going to close this bug as a duplicate of that one.

*** This bug has been marked as a duplicate of bug 969704 ***

Note You need to log in before you can comment on or make changes to this bug.