Bug 971446 - Resuming an upload results in AttributeError
Resuming an upload results in AttributeError
Status: CLOSED DUPLICATE of bug 973670
Product: Pulp
Classification: Community
Component: user-experience (Show other bugs)
2.1 Beta
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Michael Hrivnak
Preethi Thomas
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-06 10:21 EDT by Randy Barlow
Modified: 2013-09-09 12:30 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-12 09:42:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Randy Barlow 2013-06-06 10:21:30 EDT
I started an ISO upload, let it go for a bit, and then stopped it with ctrl-c. Then I tried to start the upload again and got the message telling me to look in admin.log. This was what I found in there:

I can't attach the ISO to this ticket since it's huge, but any large file will do (just needs to be large enough for you to have an opportunity to stop it before it finishes.) The file you test with doesn't even have to be an ISO.

This should reproduce:

$ pulp-admin iso repo create --repo-id uploads

$ pulp-admin iso repo uploads upload --repo-id uploads -f ~/Desktop/Fedora-17-x86_64-Live-Desktop.iso

(Stop the upload while it is still going.)

$ pulp-admin iso repo uploads resume
+----------------------------------------------------------------------+
                            Upload Requests
+----------------------------------------------------------------------+

An unexpected error has occurred. More information can be found in the client
log file ~/.pulp/admin.log.

$ tail -n 13 ~/.pulp/admin.log 
2013-06-06 10:14:55,101 - ERROR - Client-side exception occurred
Traceback (most recent call last):
  File "/home/rbarlow/devel/pulp/platform/src/pulp/client/extensions/core.py", line 478, in run
    exit_code = Cli.run(self, args)
  File "/usr/lib/python2.7/site-packages/okaara/cli.py", line 974, in run
    exit_code = command_or_section.execute(self.prompt, remaining_args)
  File "/home/rbarlow/devel/pulp/platform/src/pulp/client/extensions/extensions.py", line 224, in execute
    return self.method(*arg_list, **clean_kwargs)
  File "/home/rbarlow/devel/pulp/platform/src/pulp/client/commands/repo/upload.py", line 398, in run
    source_filenames = [os.path.basename(u.source_filename) for u in non_running_uploads]
  File "/usr/lib64/python2.7/posixpath.py", line 112, in basename
    i = p.rfind('/') + 1
AttributeError: 'NoneType' object has no attribute 'rfind'
Comment 1 Jay Dobies 2013-06-12 09:42:11 EDT
Seeing this for RPM uploads too, but I'm not surprised since it's the same underlying code. Closing this out to track in the other bug.

*** This bug has been marked as a duplicate of bug 973670 ***

Note You need to log in before you can comment on or make changes to this bug.