Bug 971454 - Desktop menu names collide between Gnome and Cinnamon
Desktop menu names collide between Gnome and Cinnamon
Status: CLOSED DUPLICATE of bug 963433
Product: Fedora
Classification: Fedora
Component: distribution (Show other bugs)
19
Unspecified Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Bill Nottingham
Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-06 10:50 EDT by oliver
Modified: 2014-03-16 23:33 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-06 11:58:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description oliver 2013-06-06 10:50:29 EDT
Description of problem:
When installing both Gnome and Cinnamon, the desktop menu names for file manager ("Files"/"Files") and system settings ("System Settings"/"Settings") show up next to each other and it is impossible to tell which is which without actually starting them up.

Version-Release number of selected component (if applicable):
cinnamon-1.9.1-1.fc19
gnome-shell-3.8.2-3.fc19

How reproducible:
Always

Steps to Reproduce:
1. Go to "Menu -> Accessories" or "Menu -> System Tools" in C
innamon, or to the equivalent Application Display in Gnome
2. Confusion!

Expected results:
Nautilus should be named "Gnome File Manager" or "Nautilus (File Manager)",
Nemo should be named "Cinnamon File Manger" or "Nemo (File Manager)",
"Settings" should be named "Gnome System Settings" or similar,
"System Settings" should be named "Cinnamon System Settings" or similar.


Additional info:
In principle, it should be able to install any number of DEs without getting entries in the menus which are specific to one DE but not identifiable as such.  I suspect there are more cases lurking.

Just a side remark: Calling a file manager menu entry "Files" seems incredibly arrogant by upstream as they are squatting on a most generic term.  I don't think Fedora as a distribution which integrates contributions from different upstreams should tolerate this.
Comment 1 Bill Nottingham 2013-06-06 11:13:51 EDT
The nautilus desktop (for example) contains:

OnlyShowIn=GNOME;Unity;

The nemo desktop also contains:

OnlyShowIn=GNOME;Unity;

What I think needs to happen here is that Cinnamon get its own desktop id, and cinnamon apps start using it.
Comment 2 oliver 2013-06-06 11:27:03 EDT
Thanks for looking into this.  The File Manager issue is not so grave as I don't think the file manager will usually be started from the menu anyway.  It just looks mildly unprofessional.

The more annoying one is the Settings where the Cinnamon settings window does not contain all relevant settings, so that, for the better or worse, both Setting applications must be available to the Cinnamon user.  I guess Cinnamon will get this worked out eventually, but right now it is really annoying because also within the settings menus there is no feedback on which settings will affect both Gnome and Cinnamon and which ones are DE specific.
Comment 3 leigh scott 2013-06-06 11:58:19 EDT
(In reply to Bill Nottingham from comment #1)
> The nautilus desktop (for example) contains:
> 
> OnlyShowIn=GNOME;Unity;
> 
> The nemo desktop also contains:
> 
> OnlyShowIn=GNOME;Unity;
> 
> What I think needs to happen here is that Cinnamon get its own desktop id,
> and cinnamon apps start using it.

This isn't going to happen.

*** This bug has been marked as a duplicate of bug 963433 ***
Comment 4 oliver 2013-06-07 02:20:44 EDT
I read bug https://bugzilla.redhat.com/show_bug.cgi?id=963433 as being specifically about nemo taking over the Gnome desktop.  So I don't see it a duplicate of this one, it's just another aspect of Cinnamon and Gnome playing nice with each other.  Please reconsider closing this one.

Note You need to log in before you can comment on or make changes to this bug.