Bug 971457 - rhpkg local (and prep) fails wiht connection timeout
Summary: rhpkg local (and prep) fails wiht connection timeout
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: rpkg (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: Unspecified Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Ales Raszka
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: EasyFix, Reopened
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-06-06 14:55 UTC by Jiri Moskovcak
Modified: 2015-08-12 13:11 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-12 13:11:21 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jiri Moskovcak 2013-06-06 14:55:52 UTC
Description of problem:
rhpkg local fails with error: Connection timeout

Version-Release number of selected component (if applicable):
rhpkg-1.14-1.el6eso.noarch

How reproducible:
100%

Steps to Reproduce:
1. clone a rhel repo
2. disconnect network
3. run rhpkg local

Actual results:
It fails

Expected results:
local build completed

Additional info:
All the required files are already downloaded, so there is no reason for rhpkg to fail.

Comment 1 Dennis Gregorovic 2014-12-16 06:15:37 UTC
This bug has been moved to JIRA:
https://projects.engineering.redhat.com/browse/RCMPROJ-2118

Comment 2 Dennis Gregorovic 2015-01-30 15:56:28 UTC
This bug was closed by accident.  Re-opening.

Comment 4 Pavol Babinčák 2015-08-06 11:28:12 UTC
Note: most likely this means checking if local tarballs exists and if they match with sources file don't try to download that.

Comment 5 Ales Raszka 2015-08-12 13:11:21 UTC
If tarball is already downloaded and match with sources file, it skip download and build it locally. 
Last modification of this part of code is in commit: https://pagure.io/rpkg/2119029072c8627856af6a2cb7f592d900201633
but this check for local files is in rpkg since commit https://pagure.io/rpkg/76772681dd89297355d1eb5b23dbc898a5061361


Note You need to log in before you can comment on or make changes to this bug.