Bug 971462 - Hotkeys not working with kernel 3.9
Hotkeys not working with kernel 3.9
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
19
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-06 11:12 EDT by Luca Cavalli
Modified: 2013-09-19 09:43 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-19 09:43:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg ouput from working kernel (3.9.2) (92.34 KB, text/plain)
2013-07-03 04:03 EDT, Hannes Ovrén
no flags Details
dmesg output from failing kernel (3.9.6) (92.33 KB, text/plain)
2013-07-03 04:04 EDT, Hannes Ovrén
no flags Details
Kernel 3.10.9 configuration file on Slackware 14. (134.37 KB, text/plain)
2013-09-09 13:03 EDT, Luca
no flags Details

  None (edit)
Description Luca Cavalli 2013-06-06 11:12:30 EDT
After switching from kernel 3.8 to kernel 3.9, hotkeys (volume, touchpad toggle, wifi hardware on/off...) stopped working and OSD doesn't appear.

Wifi hardware on/off hotkey (fn+F2 on my laptop) is the only key combination which still works, but silently, without on screen display.
Comment 1 Hannes Ovrén 2013-06-12 05:57:09 EDT
I had the same problem.

Switching from kernel 3.9.4 to 3.9.2 solves the issue.

The laptop is an Asus Zenbook Prime UX31A.
Comment 2 Josh Boyer 2013-07-01 14:21:30 EDT
Luca, what laptop?  Do any of the 3.9.y kernel updates work?  Can you attach the dmesg from both a working and failing kernel?
Comment 3 Hannes Ovrén 2013-07-03 04:03:01 EDT
No, none of the 3.9.x kernels (except 3.9.2) have worked.

I'll attach the dmesg output from my working 3.9.2 kernel, and from the latest failing kernel update (3.9.6).
Comment 4 Hannes Ovrén 2013-07-03 04:03:59 EDT
Created attachment 768129 [details]
dmesg ouput from working kernel (3.9.2)
Comment 5 Hannes Ovrén 2013-07-03 04:04:38 EDT
Created attachment 768130 [details]
dmesg output from failing kernel (3.9.6)
Comment 6 Hannes Ovrén 2013-07-05 05:02:39 EDT
The bug is still present in Fedora 19, using kernel 3.9.8.
Comment 7 Luca Cavalli 2013-07-09 02:46:32 EDT
(In reply to Josh Boyer from comment #2)
> Luca, what laptop?  Do any of the 3.9.y kernel updates work?  Can you attach
> the dmesg from both a working and failing kernel?

Sorry Josh, I was in honeymoon :)
Luckily Hannes answered your request.

I can also confirm that the bug is still present in Fedora 19.
Comment 8 Alain Devarieux 2013-07-21 09:39:35 EDT
Same problem here with my new Asus Zenbook ux32vd-r4020h.
Newly installed Fedora 19, kernel upgraded to 3.9.9 with Yum.

fn + F1 (sleep) => Works
fn + F2 (activate/deactivate Wifi) => Doesn't work
fn + F3 (decrease keyboard backlight) => Doesn't work
fn + F4 (increase keyboard backlight) => Doesn't work
fn + F5 (decrease brightness) => Doesn't work
fn + F6 (increase brightness) => Doesn't work
fn + F7 (activate/deactivate screen) => Works
fn + F8 => Not tested
fn + F9 (activate/deactivate touchpad) => Doesn't work
fn + F10 (mute sound) => Works
fn + F11 (decrease volume) => Works
fn + F12 (increase volume) => Works
Comment 9 Luca Cavalli 2013-08-26 08:25:11 EDT
Back at work after a couple of weeks of holidays. Updated the laptop with latest kernel (3.10.9-200.fc19.x86_64) and everything seems to work again.

I'm closing the bug, but feel free to reopen it in case your system is still broken.
Comment 10 Hannes Ovrén 2013-08-26 08:51:33 EDT
Nope, kernel 3.10.9-200 does not solve my problem.
Brightness keys work, but there is a substantial delay from key is pressed until it has effect and the OSD (Gnome) shows.
Other keys (volume, keyboard backlight, ...) does NOT work.

I see this message is in the output of journalctl:

asus-nb-wmi: probe of asus-nb-wmi failed with error -5

If I do a manual modprobe of asus-nb-wmi then the keys start to react when pressed, but they have a random function. I.e. pressing fn+Volume_up can produce anything from mute, volume down, brightness increase, ...

Something is really strange.
Comment 11 Luca Cavalli 2013-08-27 04:12:16 EDT
Sadly I have to rectify. Today the fn shortcuts aren't working anymore. Same kernel... Maybe it is not the actual culprit.


PS: I cannot change the bug status back to NEW, but only to ASSIGNED.
Comment 12 Luca 2013-09-09 13:02:04 EDT
Hi, I just created the account to report that I have the same problem with the brightness hotkey on a Dell Inspiron 15r 5521.

I'm running Slackware 14 64bit with kernel 3.10.9 built with config-huge configuration from slackware.com.

The other hotkeys, volume, wifi, seems working.

Ask if you need files o logs.
Luca
Comment 13 Luca 2013-09-09 13:03:35 EDT
Created attachment 795712 [details]
Kernel 3.10.9 configuration file on Slackware 14.
Comment 14 Josh Boyer 2013-09-18 16:52:26 EDT
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 19 kernel bugs.

Fedora 19 has now been rebased to 3.11.1-200.fc19.  Please test this kernel update and let us know if you issue has been resolved or if it is still present with the newer kernel.

If you experience different issues, please open a new bug report for those.
Comment 15 Hannes Ovrén 2013-09-19 03:01:09 EDT
Yes! 3.11.1-200 solved the issue for me. Thanks!
Comment 16 Josh Boyer 2013-09-19 09:43:57 EDT
Thanks for letting us know.

Note You need to log in before you can comment on or make changes to this bug.