Bug 971463 - Brand: remove non-RHEL templates and install media from default configuration
Brand: remove non-RHEL templates and install media from default configuration
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Provisioning (Show other bugs)
6.0.1
Unspecified Unspecified
unspecified Severity unspecified (vote)
: Unspecified
: --
Assigned To: Dominic Cleal
Katello QA List
: Triaged
Depends On:
Blocks: 971545
  Show dependency treegraph
 
Reported: 2013-06-06 11:13 EDT by Dominic Cleal
Modified: 2014-01-27 08:41 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-18 17:22:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dominic Cleal 2013-06-06 11:13:11 EDT
Description of problem:
Foreman ships with provisioning templates and installation media set up for a variety of operating systems.  For RH Satellite 6, it should only ship content for supported client operating systems, i.e. RHEL.

How reproducible:
Always

Steps to Reproduce:
1. In Foreman, check More>Provisioning>Installation Media
2. Check More>Provisioning>Provisioning Templates
3. Check More>Provisioning>Partition Tables

Actual results:
Installation Media: CentOS, Debian etc mirrors
Provisioning Templates: grubby, preseed and Jumpstart templates
Partition Tables: Solaris, SuSE etc entries

Expected results:
Installation Media: only media relating to Katello is listed after installation
Provisioning Templates: check PXE* and RHEL kickstart and Kickstart PXE* templates are available, plus all snippets
Partition Tables: only RedHat entries are listed
Comment 3 Dominic Cleal 2013-06-10 14:16:57 EDT
Merged in 99653e9cbc531ccfc10b77e9172fd68462c60214.
Built in 1.1.10007-1-sat.
Comment 4 Brad Buckingham 2013-06-11 15:46:05 EDT
Mass move to ON_QA
Comment 5 Tazim Kolhar 2013-06-12 05:39:12 EDT
VERIFIED :

# rpm -qa | grep katello
katello-common-1.4.2-12.el6sat.noarch
katello-selinux-1.4.3-3.el6sat.noarch
katello-configure-foreman-1.4.3-15.el6sat.noarch
ruby193-rubygem-foreman-katello-engine-0.0.8-6.el6sat.noarch
katello-configure-1.4.3-15.el6sat.noarch
katello-1.4.2-12.el6sat.noarch
katello-glue-elasticsearch-1.4.2-12.el6sat.noarch
katello-all-1.4.2-12.el6sat.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-qpid-broker-key-pair-1.0-1.noarch
katello-cli-1.4.2-7.el6sat.noarch
ruby193-rubygem-katello_api-0.0.3-2.el6_4.noarch
signo-katello-0.0.16-1.el6sat.noarch
ruby193-rubygem-katello-foreman-engine-0.0.3-4.el6sat.noarch
katello-glue-pulp-1.4.2-12.el6sat.noarch
katello-qpid-client-key-pair-1.0-1.noarch
katello-cli-common-1.4.2-7.el6sat.noarch
katello-glue-candlepin-1.4.2-12.el6sat.noarch
katello-foreman-all-1.4.2-12.el6sat.noarch
katello-certs-tools-1.4.2-2.el6sat.noarch

Installation Media: 
only media relating to Katello is listed after installation

Provisioning Templates: 
check PXE* and RHEL kickstart and Kickstart PXE* templates are available, plus all snippets

Partition Tables: only RedHat entries are listed
Comment 6 Mike McCune 2013-07-18 17:22:44 EDT
mass move to CLOSED:CURRENTRELEASE since MDP1 has been released.

Note You need to log in before you can comment on or make changes to this bug.