Bug 971504 - RFE:SSO to the RHEV User Portal
RFE:SSO to the RHEV User Portal
Status: CLOSED DUPLICATE of bug 884653
Product: oVirt
Classification: Community
Component: ovirt-engine-userportal (Show other bugs)
3.1 GA
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: Nobody's working on this, feel free to take it
infra
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-06 12:37 EDT by Valeriy
Modified: 2014-04-02 02:42 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-10 04:18:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Valeriy 2013-06-06 12:37:22 EDT
Description of problem:
We would like to have single sign on to the RHEV User Portal as well. Preferably by mod_auth_kerb as we know this works in our environment for both Linux and Windows users.

It's very useful for us to be able to use single sign on to web services. Our windows users use smart card to log on, so they don't have a password. So password login for websites just doesn't work.

Version-Release number of selected component (if applicable):
rhevm-3.1.0-43.el6ev
rhevm-userportal-3.1.0-43.el6ev
rhevm-guest-agent-1.0.5-8.el6ev
rhevm-guest-agent-gdm-plugin-1.0.5-8.el6ev
rhevm-guest-agent-pam-module-1.0.5-8.el6ev

How reproducible:
Always

Steps to Reproduce:
1. Log on to domain (IPA) machine to achive Kerberos credentials
2. Open RHEV Manager User Portal

Actual results:
Request to enter User Name and Password

Expected results:
You have signed in to the User Portal and connect directly to the virtual machine using Single Sign On (SSO).


Additional info:
N/A
Comment 3 Pavel Zhukov 2013-06-10 04:18:19 EDT

*** This bug has been marked as a duplicate of bug 884653 ***

Note You need to log in before you can comment on or make changes to this bug.