This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 971522 - sub-optimal handling of multiple partial preexisting md arrays with the same name
sub-optimal handling of multiple partial preexisting md arrays with the same ...
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
19
ppc64 All
unspecified Severity urgent
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-06 13:32 EDT by IBM Bug Proxy
Modified: 2014-03-13 15:18 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-13 15:18:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
raid10-screenshot4.png (132.64 KB, image/png)
2013-06-06 13:33 EDT, IBM Bug Proxy
no flags Details
raid10-screenshot54.png (122.96 KB, image/png)
2013-06-06 13:33 EDT, IBM Bug Proxy
no flags Details
raid10-screenshot6.png (143.78 KB, image/png)
2013-06-06 13:33 EDT, IBM Bug Proxy
no flags Details
raid10-screenshot7.png (148.72 KB, image/png)
2013-06-06 13:34 EDT, IBM Bug Proxy
no flags Details
anaconda.log (28.29 KB, text/plain)
2013-06-06 13:34 EDT, IBM Bug Proxy
no flags Details
anaconda-tb-2TXQP4 (778.90 KB, text/plain)
2013-06-06 13:34 EDT, IBM Bug Proxy
no flags Details
program.log (29.71 KB, text/plain)
2013-06-06 13:34 EDT, IBM Bug Proxy
no flags Details
storage.log (303.95 KB, text/plain)
2013-06-06 13:35 EDT, IBM Bug Proxy
no flags Details
syslog (83.99 KB, text/plain)
2013-06-06 13:35 EDT, IBM Bug Proxy
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
IBM Linux Technology Center 94452 None None None Never

  None (edit)
Description IBM Bug Proxy 2013-06-06 13:32:53 EDT
== Comment: #0 - MANAS K. NAYAK <maknayak@in.ibm.com> - 2013-06-06 10:10:48 ==
Selected two disks for RAID10 installation on Fedora19 ppc64 Beta installation on P7 LPAR, right after 10/15 % of installation progress noticed below unknown error for "FormatSetupError: invalid device specification" and installation got blocked there.

--- Captured from anaconda-tb log ---
anaconda 19.30-1 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.7/site-packages/blivet/formats/__init__.py", line 346, in setup
    raise FormatSetupError("invalid device specification")
  File "/usr/lib/python2.7/site-packages/blivet/devices.py", line 840, in setupParents
    _format.setup()
  File "/usr/lib/python2.7/site-packages/blivet/devices.py", line 703, in _preSetup
    self.setupParents(orig=orig)
  File "/usr/lib/python2.7/site-packages/blivet/devices.py", line 714, in setup
    if not self._preSetup(orig=orig):
  File "/usr/lib/python2.7/site-packages/blivet/devices.py", line 832, in setupParents
    parent.setup(orig=orig)
  File "/usr/lib/python2.7/site-packages/blivet/devices.py", line 2197, in _preDestroy
    self.setupParents(orig=True)
  File "/usr/lib/python2.7/site-packages/blivet/devices.py", line 820, in destroy
    self._preDestroy()
  File "/usr/lib/python2.7/site-packages/blivet/deviceaction.py", line 318, in execute
    self.device.destroy()
  File "/usr/lib/python2.7/site-packages/blivet/devicetree.py", line 237, in processActions
    action.execute()
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 306, in doIt
    self.devicetree.processActions()
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 165, in turnOnFilesystems
    storage.doIt()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/install.py", line 138, in doInstall
    turnOnFilesystems(storage, mountOnly=flags.flags.dirInstall)
  File "/usr/lib64/python2.7/threading.py", line 766, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 168, in run
    threading.Thread.run(self, *args, **kwargs)
FormatSetupError: invalid device specification

Local variables in innermost frame:
device: None
self: existing mdmember
args: ()
kwargs: {}


--- Steps to reproduce ---
1) Boot from virtual DVD of Fedora19 beta ppc64
2) Proceed for VNC installation
3) Reclaim space if any
4) select two disks for installation
5) Make sure partition scheme LVM must be selected and "I want to review or modify disk partitions before continuing" must be enabled .
6) click on continue
7) On Manual Partition Scheme page, click on create file system automatically .
8) select / and then click on Modify
9) On configure volume group screen : select RAID level to RAID10
10) Click on Save and then click on Done
11) Accept Changes
12) click on "Begin Installation"
13) After 10 to 15 % of installation progress gets over , you will notice "unknown error : FormatSetupError: invalid device specification"


--- Attached logs ---

Screenshots:  
                  raid10-screenshot4.png , raid10-screenshot5.png, raid10-screenshot6.png , 
                  raid10-screenshot7.png

Anaconda logs:
                   anaconda.log,  anaconda-tb-2TXQP4,  program.log,  storage.log syslog

== Comment: #1 - MANAS K. NAYAK <maknayak@in.ibm.com> - 2013-06-06 10:11:56 ==


== Comment: #2 - MANAS K. NAYAK <maknayak@in.ibm.com> - 2013-06-06 10:13:16 ==


== Comment: #3 - MANAS K. NAYAK <maknayak@in.ibm.com> - 2013-06-06 10:13:56 ==


== Comment: #4 - MANAS K. NAYAK <maknayak@in.ibm.com> - 2013-06-06 10:14:55 ==


== Comment: #5 - MANAS K. NAYAK <maknayak@in.ibm.com> - 2013-06-06 10:16:26 ==


== Comment: #6 - MANAS K. NAYAK <maknayak@in.ibm.com> - 2013-06-06 10:17:22 ==


== Comment: #7 - MANAS K. NAYAK <maknayak@in.ibm.com> - 2013-06-06 10:17:55 ==


== Comment: #8 - MANAS K. NAYAK <maknayak@in.ibm.com> - 2013-06-06 10:18:35 ==


== Comment: #9 - MANAS K. NAYAK <maknayak@in.ibm.com> - 2013-06-06 10:19:04 ==


== Comment: #10 - Brent J. Baude <baude@us.ibm.com> - 2013-06-06 10:32:18 ==
is the replicatable if you zero all the disks first?  Please try that, it's a valuable piece of information.
Comment 1 IBM Bug Proxy 2013-06-06 13:33:17 EDT
Created attachment 757785 [details]
raid10-screenshot4.png
Comment 2 IBM Bug Proxy 2013-06-06 13:33:34 EDT
Created attachment 757786 [details]
raid10-screenshot54.png
Comment 3 IBM Bug Proxy 2013-06-06 13:33:48 EDT
Created attachment 757787 [details]
raid10-screenshot6.png
Comment 4 IBM Bug Proxy 2013-06-06 13:34:03 EDT
Created attachment 757788 [details]
raid10-screenshot7.png
Comment 5 IBM Bug Proxy 2013-06-06 13:34:18 EDT
Created attachment 757789 [details]
anaconda.log
Comment 6 IBM Bug Proxy 2013-06-06 13:34:39 EDT
Created attachment 757790 [details]
anaconda-tb-2TXQP4
Comment 7 IBM Bug Proxy 2013-06-06 13:34:56 EDT
Created attachment 757791 [details]
program.log
Comment 8 IBM Bug Proxy 2013-06-06 13:35:18 EDT
Created attachment 757798 [details]
storage.log
Comment 9 IBM Bug Proxy 2013-06-06 13:35:40 EDT
Created attachment 757803 [details]
syslog
Comment 10 David Lehman 2013-06-06 17:08:18 EDT
This looks like a bug that only occurs in test environments where hardware is switched around sloppily. I can see that there are multiple preexisting (partial?) md arrays that all have the same name. It would be nice to handle this more smoothly, but it is by no means a high priority to make up for poor administration practices. You should be clearing metadata from disks when you move them from one system to another, not just from the partition table, but also from each partition.

Note You need to log in before you can comment on or make changes to this bug.