Bug 971527 - error logs showing wrong cartridge version after recent ugprade
Summary: error logs showing wrong cartridge version after recent ugprade
Status: CLOSED DUPLICATE of bug 969953
Alias: None
Product: OpenShift Online
Classification: Red Hat
Component: Containers   
(Show other bugs)
Version: 2.x
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: ---
Assignee: Mrunal Patel
QA Contact: libra bugs
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 971586
TreeView+ depends on / blocked
 
Reported: 2013-06-06 18:09 UTC by Sumana Annam
Modified: 2015-05-14 23:21 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 971586 (view as bug list)
Environment:
Last Closed: 2013-06-06 21:41:00 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Comment 1 Jhon Honce 2013-06-06 20:56:00 UTC
Description of problem:

Python:

https://www.openshift.com/forums/openshift/deployment-error-with-python-27-cartridge


2) Python:

During a git push, I get some errors, and the deployment of my application fails.

I'm not sure why python 2.6 appears in the paths below since this is a python 2.7 cartridge.

It looks like someone recently posted a similar error on Bugzilla for apps that use pymongo, and my app uses pymongo. https://bugzilla.redhat.com/show_bug.cgi?id=969953

Any help would be really appreciated!


remote: Installing setuptools................................................
remote:   Complete output from command /var/lib/openshift/5...n/virtenv/bin/python -c "#!python
remote: \"\"\"Bootstra...sys.argv[1:])
remote: NameError: global name 're' is not defined
remote: ----------------------------------------
remote: ...Installing setuptools...done.
remote: Traceback (most recent call last):
remote:   File "/usr/lib/python2.6/site-packages/virtualenv.py", line 2577, in <module>
remote:     main()
remote:   File "/usr/lib/python2.6/site-packages/virtualenv.py", line 979, in main
remote:     no_pip=options.no_pip)
remote:   File "/usr/lib/python2.6/site-packages/virtualenv.py", line 1091, in create_environment
remote:     search_dirs=search_dirs, never_download=never_download)
remote:   File "/usr/lib/python2.6/site-packages/virtualenv.py", line 611, in install_setuptools
remote:     search_dirs=search_dirs, never_download=never_download)
remote:   File "/usr/lib/python2.6/site-packages/virtualenv.py", line 583, in _install_req
remote:     cwd=cwd)
remote:   File "/usr/lib/python2.6/site-packages/virtualenv.py", line 1057, in call_subprocess
remote:     % (cmd_desc, proc.returncode))
remote: OSError: Command /var/lib/openshift/5...n/virtenv/bin/python -c "#!python
remote: \"\"\"Bootstra...sys.argv[1:])


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 2 Mrunal Patel 2013-06-06 21:40:14 UTC
The python-2.6 showing up in the backtrace isn't really the issue here.
It is because we use the virtualenv tool installed to system python-2.6
The real issue is the corrupted virtualenv for which we already have a bug open.

Comment 3 Mrunal Patel 2013-06-06 21:41:00 UTC

*** This bug has been marked as a duplicate of bug 969953 ***


Note You need to log in before you can comment on or make changes to this bug.