Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 971528 - Gluster fuse mount corrupted
Summary: Gluster fuse mount corrupted
Keywords:
Status: CLOSED DEFERRED
Alias: None
Product: GlusterFS
Classification: Community
Component: fuse
Version: 3.3.1
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-06-06 18:12 UTC by dsgh1
Modified: 2014-12-14 19:40 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-12-14 19:40:31 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description dsgh1 2013-06-06 18:12:49 UTC
Description of problem:

After a network restart of a gluster client, the gluster fuse mount was in a corrupted state.  ls -la showed listings:

drwxr-s---   3 XXXX XXXX    72 Apr  2 02:00 calbo
?---------   ? ?         ?          ?            ? calbr
drwxr-sr-x   3 XXXX XXXX    72 May 28 02:01 calch
drwxr-s---   3 XXXX XXXX    72 Jun  6 08:28 calgi
?---------   ? ?         ?          ?            ? calhu

The unknown state directories were inaccessible (return non-existent)

The glusterfs logs had entries:

[2013-06-06 05:13:01.669720] W [dht-layout.c:186:dht_layout_search] 0-attachments-dht: no subvolume for hash (value) = 1094163728
[2013-06-06 05:13:01.669732] E [dht-common.c:1372:dht_lookup] 0-attachments-dht: Failed to get hashed subvol for /.emrExternalStore
[2013-06-06 05:13:01.669742] W [fuse-bridge.c:292:fuse_entry_cbk] 0-glusterfs-fuse: 1541616503: LOOKUP() /.emrExternalStore => -1 (Invalid argument)
[2013-06-06 05:13:01.845980] W [dht-layout.c:186:dht_layout_search] 0-attachments-dht: no subvolume for hash (value) = 1094163728
[2013-06-06 05:13:01.846008] E [dht-common.c:1372:dht_lookup] 0-attachments-dht: Failed to get hashed subvol for /.emrExternalStore
[2013-06-06 05:13:01.846024] W [fuse-bridge.c:292:fuse_entry_cbk] 0-glusterfs-fuse: 1541616504: LOOKUP() /.emrExternalStore => -1 (Invalid argument)

Unmounting and remounting the gluster fuse mount restored operation to normal.  However, the question is, why did the gluster fuse mount not handle the network restart gracefully?  (Total time of network outage 20 seconds).

Version-Release number of selected component (if applicable):

3.3.1 for all components

How reproducible:

This happened on a production server.  Cannot reproduce

Steps to Reproduce:
1.
2.
3.

Actual results:

Gluster client got a corrupted mount after a network restart.


Expected results:

Gluster client would restore mount after network restart.


Additional info:

Comment 1 Niels de Vos 2014-11-27 14:54:28 UTC
The version that this bug has been reported against, does not get any updates from the Gluster Community anymore. Please verify if this report is still valid against a current (3.4, 3.5 or 3.6) release and update the version, or close this bug.

If there has been no update before 9 December 2014, this bug will get automatocally closed.


Note You need to log in before you can comment on or make changes to this bug.