Bug 971565 - nova-compute appears to be leaking qpid exchanges
nova-compute appears to be leaking qpid exchanges
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-nova (Show other bugs)
3.0
Unspecified Unspecified
high Severity high
: rc
: 3.0
Assigned To: Nikola Dipanov
Jaroslav Henner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-06 16:12 EDT by Flavio Percoco
Modified: 2016-04-26 16:43 EDT (History)
9 users (show)

See Also:
Fixed In Version: openstack-nova-2013.1.2-2.el6ost
Doc Type: Bug Fix
Doc Text:
The Compute Conductor (openstack-nova-conductor) service was not correctly closing Qpid message exchanges. As a result after several hours of operations many open exchanges would remain in existence. The Compute Conductor service has been updated and now closes Qpid message exchanges correctly when they are no longer needed.
Story Points: ---
Clone Of: 960539
Environment:
Last Closed: 2013-06-27 13:16:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Flavio Percoco 2013-06-06 16:12:58 EDT
+++ This bug was initially created as a clone of Bug #960539 +++

From RDO forum user bostrick: http://openstack.redhat.com/forum/discussion/85/is-nova-conductor-leaking-qpid-exchanges

Description of problem: After several hours of operation, there are a large number of qpid exchanges in existence, with a new one being created every ~10s.

To reproduce:
* Start OpenStack
* After a while, run qpid-stat -e lists open exchanges.

Actual results: Many exchanges reported.

Expected results: Few/no exchanges reported


Additional info:

qpid-printevents is displaying transactions similar to the following every 10 secs:

org.apache.qpid.broker:exchangeDeclare ... exName=d75b1d8f76ea46eead02b7480dd28cdf ...
org.apache.qpid.broker:queueDeclare ... qName=d75b1d8f76ea46eead02b7480dd28cdf ...
org.apache.qpid.broker:bind ... exName=d75b1d8f76ea46eead02b7480dd28cdf ...
org.apache.qpid.broker:subscribe ... qName=d75b1d8f76ea46eead02b7480dd28cdf ...
org.apache.qpid.broker:unsubscribe ...
org.apache.qpid.broker:queueDelete ... qName=d75b1d8f76ea46eead02b7480dd28cdf

notably missing is a complement to "exchangeDeclare" to clean it up.

tracing qpid client ports, nova-conductor seems to be the culprit.
Comment 4 Jaroslav Henner 2013-06-13 10:16:04 EDT
# qpid-stat -e | wc -l
28
# qpid-config exchanges | wc -l
27

Whereas on unfixed system

# qpid-config exchanges | wc -l
557
# qpid-stat -e | wc -l
577
Comment 7 errata-xmlrpc 2013-06-27 13:16:29 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0968.html

Note You need to log in before you can comment on or make changes to this bug.