Bug 971574 - ceilometer appears to be leaking qpid exchanges
ceilometer appears to be leaking qpid exchanges
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-ceilometer (Show other bugs)
3.0
Unspecified Unspecified
high Severity high
: rc
: 3.0
Assigned To: Pádraig Brady
Ami Jeain
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-06 16:26 EDT by Flavio Percoco
Modified: 2016-01-04 09:42 EST (History)
12 users (show)

See Also:
Fixed In Version: openstack-ceilometer-2013.1.2-2.el6ost
Doc Type: Bug Fix
Doc Text:
Previously, multiple qpid exchanges were created by Ceilometer but not removed if not required, leading to system out of memory errors. This has been fixed by appropriate configuration so that unnecessary qpid exchanges are removed.
Story Points: ---
Clone Of: 960539
Environment:
Last Closed: 2013-06-27 13:16:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Flavio Percoco 2013-06-06 16:26:15 EDT
+++ This bug was initially created as a clone of Bug #960539 +++

From RDO forum user bostrick: http://openstack.redhat.com/forum/discussion/85/is-nova-conductor-leaking-qpid-exchanges

Description of problem: After several hours of operation, there are a large number of qpid exchanges in existence, with a new one being created every ~10s.

To reproduce:
* Start OpenStack
* After a while, run qpid-stat -e lists open exchanges.

Actual results: Many exchanges reported.

Expected results: Few/no exchanges reported


Additional info:

qpid-printevents is displaying transactions similar to the following every 10 secs:

org.apache.qpid.broker:exchangeDeclare ... exName=d75b1d8f76ea46eead02b7480dd28cdf ...
org.apache.qpid.broker:queueDeclare ... qName=d75b1d8f76ea46eead02b7480dd28cdf ...
org.apache.qpid.broker:bind ... exName=d75b1d8f76ea46eead02b7480dd28cdf ...
org.apache.qpid.broker:subscribe ... qName=d75b1d8f76ea46eead02b7480dd28cdf ...
org.apache.qpid.broker:unsubscribe ...
org.apache.qpid.broker:queueDelete ... qName=d75b1d8f76ea46eead02b7480dd28cdf

notably missing is a complement to "exchangeDeclare" to clean it up.

tracing qpid client ports, nova-conductor seems to be the culprit.

--- Additional comment from David Ripton on 2013-06-06 16:12:52 EDT ---

Related upstream bugs:

https://bugs.launchpad.net/oslo/+bug/1033915
https://bugs.launchpad.net/nova/+bug/1178375
Comment 1 Eoghan Glynn 2013-06-10 10:15:23 EDT
The underlying issue is the oslo RPC layer.

The patch to address that is currently stalled upstream with gate failures:

  https://review.openstack.org/32187

The usual olso "managed copy'n'paste" process can be followed once there's traction on this review.
Comment 2 Jay Turner 2013-06-10 12:51:31 EDT
QE ack.  We have a reproducer and a proposed patch.  Although the fact it is stalled upstream could cause some issues given the RC build schedule.
Comment 3 Pádraig Brady 2013-06-11 12:02:04 EDT
Fix suggested by Russel Bryant was to config out the problematic path:
http://pkgs.devel.redhat.com/cgit/rpms/openstack-ceilometer/commit/?h=rh-grizzly-rhel-6&id=ff04ad624
Comment 5 Ami Jeain 2013-06-17 08:32:58 EDT
#  qpid-stat -e |wc -l
49
#  qpid-stat -e |wc -l
49
Comment 8 errata-xmlrpc 2013-06-27 13:16:57 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0968.html

Note You need to log in before you can comment on or make changes to this bug.