Bug 971584 - PDQ patches incorrectly default "mount_check" option to "False"
PDQ patches incorrectly default "mount_check" option to "False"
Status: CLOSED NOTABUG
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: gluster-swift (Show other bugs)
2.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Luis Pabón
pushpesh sharma
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-06 16:45 EDT by Peter Portante
Modified: 2016-11-08 17:24 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-08 06:22:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Portante 2013-06-06 16:45:25 EDT
The PDQ gluster-swift-plugin RPMs default the account, container and object server "mount_check" option to "false" in the sample configuration files. This can be dangerous, and helpful to new users, where if they don't have the gluster volume properly mounted, their Swift REST API based file creations will possibly occur on the root volume if they are not careful.

This option should default to "true", and the sample configuration file should advise customers to only turn this off after they are confident their volumes are always mounted ahead of the swift *-server processes.
Comment 2 Peter Portante 2013-06-08 06:22:30 EDT
This is not a bug.

For the RHS 2.0 based code, including PDQ, the mount_check option is false to prevent the swift code from doing the mount checking, allowing DiskFile and DiskDir modules to do it. Upstream they are integrated and so this only matters there.

Note You need to log in before you can comment on or make changes to this bug.