Bug 971598 - [RHEL6] Yum config manager confuses ID and name
[RHEL6] Yum config manager confuses ID and name
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: yum-utils (Show other bugs)
6.4
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: packaging-team-maint
Karel Srot
:
Depends On:
Blocks: 1005265 1098442
  Show dependency treegraph
 
Reported: 2013-06-06 17:41 EDT by Ben Woodard
Modified: 2014-10-14 00:38 EDT (History)
6 users (show)

See Also:
Fixed In Version: yum-utils-1.1.30-27.el6
Doc Type: Bug Fix
Doc Text:
NO DOCS NEEDED
Story Points: ---
Clone Of:
: 971599 1098442 (view as bug list)
Environment:
Last Closed: 2014-10-14 00:38:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ben Woodard 2013-06-06 17:41:08 EDT
Description of problem:
Evidently yum config manager confuses ID and name. 


<james> And can yum see it in "yum repolist" ?
<neb> in the list it appears to be:
<neb> rhel-6-server-optional-rpms
<neb> vs
<neb> rhel-server-optional-6-rpms
<james> Are the id and names different?
<james> yum-config-manager just takes ids
<james> repolist does both, IIRC.
<neb> doh that is subtle
<james> ugh … even worse yum-config-manager seems to take names only … doh!
<james> that can't be right.
<james> oh … the code is using name for id … nice.
<james> yeh, repolist has it's own find routine … I can fix that for RHEL-7, probably.
<neb> great. no wonder it had me so confused.
<james> neb: If you could file a RHEL-7 bug/RFE that'd be great.
<neb> this is still rhel6 though
<james> Yeh, you can file a bug there too … I just wouldn't hold your breath.
<neb> still want one for rhel7 but not rhel6
<james> Maybe for 6.6 or whatever.
<neb> OK

Version-Release number of selected component (if applicable):
yum-utils-1.1.30-14.el6.noarch
Comment 2 RHEL Product and Program Management 2013-10-13 19:30:08 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 3 James Antill 2014-03-25 12:07:49 EDT
 This is upstream, but requires yum and yum-utils patches:

commit 65d1cd21418b140e7ab74e568b16067a1b01d2c9
Author: James Antill <james@and.org>
Date:   Fri Jun 7 11:37:32 2013 -0400

    Extend findRepos() so it can work like repolist. BZ 971599.


commit 08fa4c95c35e17cc099a178edcaf7ecc1fb1fcb9
Author: James Antill <james@and.org>
Date:   Tue Jun 18 15:11:18 2013 -0400

    Use new findRepos() API for yum-config-manager. BZ 971599.
Comment 10 errata-xmlrpc 2014-10-14 00:38:10 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1411.html

Note You need to log in before you can comment on or make changes to this bug.