Bug 971622 - [abrt] gconf-editor-3.0.1-3.fc18: g_str_hash: Process /usr/bin/gconf-editor was killed by signal 11 (SIGSEGV)
[abrt] gconf-editor-3.0.1-3.fc18: g_str_hash: Process /usr/bin/gconf-editor w...
Status: CLOSED DUPLICATE of bug 807618
Product: Fedora
Classification: Fedora
Component: gconf-editor (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
abrt_hash:a916fe6c7990f68bef1ac3c1157...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-06 20:24 EDT by Pavel Roskin
Modified: 2013-06-07 09:33 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-07 09:33:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (29.26 KB, text/plain)
2013-06-06 20:24 EDT, Pavel Roskin
no flags Details
File: cgroup (129 bytes, text/plain)
2013-06-06 20:24 EDT, Pavel Roskin
no flags Details
File: core_backtrace (5.30 KB, text/plain)
2013-06-06 20:24 EDT, Pavel Roskin
no flags Details
File: dso_list (8.22 KB, text/plain)
2013-06-06 20:24 EDT, Pavel Roskin
no flags Details
File: environ (2.88 KB, text/plain)
2013-06-06 20:24 EDT, Pavel Roskin
no flags Details
File: limits (1.29 KB, text/plain)
2013-06-06 20:24 EDT, Pavel Roskin
no flags Details
File: maps (41.74 KB, text/plain)
2013-06-06 20:24 EDT, Pavel Roskin
no flags Details
File: open_fds (582 bytes, text/plain)
2013-06-06 20:24 EDT, Pavel Roskin
no flags Details
File: proc_pid_status (791 bytes, text/plain)
2013-06-06 20:24 EDT, Pavel Roskin
no flags Details
File: var_log_messages (1.19 KB, text/plain)
2013-06-06 20:24 EDT, Pavel Roskin
no flags Details
File: xsession_errors (267 bytes, text/plain)
2013-06-06 20:24 EDT, Pavel Roskin
no flags Details

  None (edit)
Description Pavel Roskin 2013-06-06 20:24:20 EDT
Description of problem:
Run gconf-editor.  Select any boolean key with the mouse (/apps/gnome-terminal/global/confirm_window_close was used to generate this report).  Select "/" on top on the left pane.  gconf-editor crashes immediately.  The problem is reproducible every time.  One of the following messages is shown on the terminal where gconf-editor was run:

(gconf-editor:2146): GConf-CRITICAL **: gconf_client_key_is_writable: assertion `key != NULL' failed

or

GConf:ERROR:gconf-client.c:2369:gconf_client_lookup: assertion failed: (last_slash != NULL)

I'm running LXDE.  gconfd-2 is running.  gconf-editor shows "This key is not writable" for all keys.  However, the checkboxes for boolean options are enabled (perhaps wrongly).

Version-Release number of selected component:
gconf-editor-3.0.1-3.fc18

Additional info:
reporter:       libreport-2.1.4
backtrace_rating: 4
cmdline:        gconf-editor
crash_function: g_str_hash
executable:     /usr/bin/gconf-editor
gconf_subtree:   bookmarks = []
kernel:         3.10.0-rc4+
runlevel:       N 5
uid:            1000

Truncated backtrace:
Thread no. 1 (10 frames)
 #0 g_str_hash at ghash.c:1730
 #1 g_hash_table_lookup_node at ghash.c:401
 #2 g_hash_table_lookup at ghash.c:1074
 #3 gconf_client_lookup at gconf-client.c:2359
 #4 get at gconf-client.c:1474
 #5 gconf_client_get_entry at gconf-client.c:1577
 #6 gconf_client_get_schema_for_key at gconf-util.c:87
 #7 gconf_editor_window_update_list_selection at gconf-editor-window.c:1136
 #8 _g_closure_invoke_va at gclosure.c:840
 #10 g_signal_emit_by_name at gsignal.c:3393

Potential duplicate: bug 836271
Comment 1 Pavel Roskin 2013-06-06 20:24:23 EDT
Created attachment 757952 [details]
File: backtrace
Comment 2 Pavel Roskin 2013-06-06 20:24:26 EDT
Created attachment 757953 [details]
File: cgroup
Comment 3 Pavel Roskin 2013-06-06 20:24:28 EDT
Created attachment 757954 [details]
File: core_backtrace
Comment 4 Pavel Roskin 2013-06-06 20:24:31 EDT
Created attachment 757955 [details]
File: dso_list
Comment 5 Pavel Roskin 2013-06-06 20:24:34 EDT
Created attachment 757956 [details]
File: environ
Comment 6 Pavel Roskin 2013-06-06 20:24:36 EDT
Created attachment 757957 [details]
File: limits
Comment 7 Pavel Roskin 2013-06-06 20:24:39 EDT
Created attachment 757958 [details]
File: maps
Comment 8 Pavel Roskin 2013-06-06 20:24:42 EDT
Created attachment 757959 [details]
File: open_fds
Comment 9 Pavel Roskin 2013-06-06 20:24:44 EDT
Created attachment 757960 [details]
File: proc_pid_status
Comment 10 Pavel Roskin 2013-06-06 20:24:47 EDT
Created attachment 757961 [details]
File: var_log_messages
Comment 11 Pavel Roskin 2013-06-06 20:24:50 EDT
Created attachment 757962 [details]
File: xsession_errors
Comment 12 Pavel Roskin 2013-06-07 09:33:37 EDT
This is essentially a duplicate of bug 807618.  I just hit a more rare assertion failure:

(gconf-editor:2146): GConf-CRITICAL **: gconf_client_key_is_writable: assertion `key != NULL' failed

I would more often get

GConf:ERROR:gconf-client.c:2369:gconf_client_lookup: assertion failed: (last_slash != NULL)

The later is discussed in bug 807618.  The way to trigger both assertions is exactly the same.

*** This bug has been marked as a duplicate of bug 807618 ***

Note You need to log in before you can comment on or make changes to this bug.