This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 971652 - [Document List] Clicking column header "Complete" mistakenly sort by other column you sort
[Document List] Clicking column header "Complete" mistakenly sort by other co...
Status: CLOSED CURRENTRELEASE
Product: Zanata
Classification: Community
Component: Component-UI (Show other bugs)
3.0
Unspecified Unspecified
unspecified Severity medium
: ---
: 3.5
Assigned To: Alex Eng
Ding-Yi Chen
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-07 01:12 EDT by Ding-Yi Chen
Modified: 2015-01-26 18:28 EST (History)
1 user (show)

See Also:
Fixed In Version: 3.5.0-SNAPSHOT (git-server-3.4.1-38-gbf555f5)
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-01-26 18:28:01 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ding-Yi Chen 2013-06-07 01:12:06 EDT
Description of problem:
In document list view, clicking the column header "Complete" should sort by the number of "complete". However, if you clicked other columns before, the actual result is sorted by that column instead.


Version-Release number of selected component (if applicable):
Zanata version 3.0.0-SNAPSHOT (20130607-1221)

How reproducible:
Always

Steps to Reproduce:
1. Navigate to document list view of any project that has many documents.
2. Click at any other column that make the "Complete" column unsorted.
3. Click at "Complete"

Actual results:
The documents are sorted by the column you choose on step 2.

Expected results:
The documents should be sorted by "Completed".

Additional info:
Comment 1 Alex Eng 2014-05-27 21:16:33 EDT
UI has been changed since 3.3.0
Comment 2 Ding-Yi Chen 2014-05-27 23:31:41 EDT
The GWT document list still existed in Zanata 3.5.0-SNAPSHOT (git-server-3.4.1-34-g17ffcd7)
Comment 3 Alex Eng 2014-05-27 23:42:40 EDT
Pull request:
https://github.com/zanata/zanata-server/pull/469
Comment 4 Ding-Yi Chen 2014-06-01 20:37:49 EDT
VERIFIED with Zanata 3.5.0-SNAPSHOT (git-server-3.4.1-38-gbf555f5)

Note You need to log in before you can comment on or make changes to this bug.