Bug 971658 - [RHS-C] Incorrect error message while performing Enable/Disable actions on a cluster with no UP servers
[RHS-C] Incorrect error message while performing Enable/Disable actions on a ...
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhsc (Show other bugs)
2.1
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Sahina Bose
Prasanth
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-07 01:57 EDT by Prasanth
Modified: 2013-09-23 18:25 EDT (History)
8 users (show)

See Also:
Fixed In Version: bb4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-23 18:25:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot of error (128.62 KB, image/png)
2013-06-07 01:57 EDT, Prasanth
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 15711 None None None Never

  None (edit)
Description Prasanth 2013-06-07 01:57:57 EDT
Created attachment 757987 [details]
screenshot of error

Description of problem:

Incorrect error message while performing Enable/Disable actions on a cluster with no UP servers

Version-Release number of selected component (if applicable):  Red Hat Storage Console Version: 2.1.0-0.bb2.el6rhs 


How reproducible: Always


Steps to Reproduce:
1. Put all the servers in a cluster into Maintenance mode.
2. Click on Clusters
3. Select a cluster and click on "Gluster Hooks" sub-tab
4. Try to Enable/Disable some hooks and watch the error

Actual results: Incorrect error message


Expected results: Error message should be accurate


Additional info: Screenshot attached
Comment 2 Prasanth 2013-06-13 03:12:54 EDT
Current Error message:

-------
Error while executing action:

    VAR__ACTION__ENABLE
    Cannot ${action} Gluster Hook. No up server found in mycluster.
-------
Comment 3 Prasanth 2013-06-24 07:45:16 EDT
Verified as fixed in bb4. Now the error messages appears as follows:

----=------
Error while executing action: Cannot disable Gluster Hook. No up server found in cluster1.

Error while executing action: Cannot enable Gluster Hook. No up server found in cluster1.
----=------
Comment 4 Scott Haines 2013-09-23 18:25:44 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html

Note You need to log in before you can comment on or make changes to this bug.