Bug 971668 - Decision table in a CSV file is not included in KieBase
Decision table in a CSV file is not included in KieBase
Status: CLOSED CURRENTRELEASE
Product: JBoss BRMS Platform 6
Classification: JBoss
Component: BRE (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity high
: DR6
: 6.0.0
Assigned To: Edson Tirelli
Marek Winkler
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-07 02:10 EDT by Marek Winkler
Modified: 2014-08-06 16:18 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:18:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marek Winkler 2013-06-07 02:10:06 EDT
Description of problem:

A KieBase containing only a CSV file is defined in kmodule.xml, when this KieBase is obtained from a KieContainer, the KieBase is empty. During construction of the KieBase, the following warning is displayed:

2013-06-07 07:53:40,853 [main] WARN  No files found for KieBase kbaseCSV, searching folder /home/mwinkler/work/repositories/droolsjbpm/drools/drools-decisiontables/target/test-classes

The same test works for a KieBase with XLS file.

Version-Release number of selected component (if applicable):

Drools 6.0.0.Beta3
Drools 6.0.0-SNAPSHOT

BRMS 6.0.0 DR4

How reproducible:

Run reproducer test org.drools.decisiontable.integrationtests.KModuleWithDecisionTablesTest#testNonEmptyKieBaseWithCSV in drools-decisiontables. (I will attach link to the pull request with the reproducer shortly.)

Actual results:

The test testNonEmptyKieBaseWithCSV fails because the KieBase is empty.

Expected results:

The test testNonEmptyKieBaseWithCSV should succeed.
Comment 1 Marek Winkler 2013-06-07 02:18:08 EDT
Created pull request with a reproducer in drools-decisiontables: https://github.com/droolsjbpm/drools/pull/210
Comment 3 Marek Winkler 2013-08-08 11:12:06 EDT
Verified on 6.0.0.DR6.

Note You need to log in before you can comment on or make changes to this bug.