Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 971673 - RHEV-H will hung for a long time if simultaneously operation the logging menu on local host and serial console
RHEV-H will hung for a long time if simultaneously operation the logging menu...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.4
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Fabian Deutsch
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-07 02:22 EDT by cshao
Modified: 2014-01-21 14:35 EST (History)
14 users (show)

See Also:
Fixed In Version: ovirt-node-3.0.1-2.el6
Doc Type: Bug Fix
Doc Text:
The hypervisor was hanging for a long time if simultaneously operating the logging menu on local host and serial console. This has been fixed using a transaction lock (python-lockfile) so the hypervisor no longer hangs.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-21 14:35:21 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
hung (9.80 KB, image/png)
2013-06-07 02:22 EDT, cshao
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:0033 normal SHIPPED_LIVE ovirt-node bug fix and enhancement update 2014-01-21 19:14:30 EST

  None (edit)
Description cshao 2013-06-07 02:22:15 EDT
Created attachment 757991 [details]
hung

Description of problem:
RHEV-H will hung for a long time(more than 5 mins) if simultaneously operation the logging menu on local host and serial console.

Version-Release number of selected component (if applicable):
rhev-hypervisor6-6.4-20130528.0.el6_4

How reproducible:
100%

Steps to Reproduce:
1. Install RHEV-H, configure network.
2. In local host: Enter logging menu and set rsyslog address, and move cursor to apply option but don't press "enter" key.(e.g. 10.66.10.110)
3. In serial console: Enter logging menu and set different rsyslog address. and move cursor to apply option but don't press "enter" key.(e.g. 10.66.10.111)
4. Press "enter" key on local host and serial console simultaneously.

Actual results:
RHEV-H will hung on "applying configuration" for a long time(more than 5 mins)

Expected results:
RHEV-H can receive the latest configure and no hung.

Additional info:
Comment 2 Mike Burns 2013-06-07 07:52:04 EDT
seems we might need to add some sort of transaction locking so that we don't try this twice at the same time.  

Fabian, any thoughts?
Comment 3 Fabian Deutsch 2013-06-10 05:02:36 EDT
(In reply to Mike Burns from comment #2)
> seems we might need to add some sort of transaction locking so that we don't
> try this twice at the same time.  
> 
> Fabian, any thoughts?

Yes, using a lock is probably a good idea.
I'd use a file based locking mechanism to have an inter process locking mechanism. python-lockfile is a candidate for this.
Comment 4 Fabian Deutsch 2013-09-17 04:55:03 EDT
This has been fixed upstream in commit d605941643269611787159d70e69ca8ad2069001 and was merged during the 3.0 cycle.
Comment 5 Fabian Deutsch 2013-09-17 04:56:44 EDT
(In reply to Fabian Deutsch from comment #4)
> This has been fixed upstream in commit
> d605941643269611787159d70e69ca8ad2069001 and was merged during the 3.0 cycle.

The expected behavior is that an exception is raised when a new transaction is initiated (when pressing <Save> on a page) while another one is still running.
Comment 10 cshao 2013-10-24 23:16:26 EDT
Test version:
rhev-hypervisor6-6.5-20131017.0
ovirt-node-3.0.1-4.el6.noarch

Test steps:
1. Install RHEV-H, configure network.
2. In local host: Enter logging menu and set rsyslog address, and move cursor to apply option but don't press "enter" key.(e.g. 10.66.10.110)
3. In serial console: Enter logging menu and set different rsyslog address. and move cursor to apply option but don't press "enter" key.(e.g. 10.66.10.111)
4. Press "enter" key on local host and serial console simultaneously.

Test result:
RHEV-H can receive the latest configure and no hung.

So the bug is fixed, change bug status to VERIFIED.
Comment 13 Cheryn Tan 2013-11-07 19:36:50 EST
This bug is currently attached to errata RHBA-2013:15277. If this change is not to be documented in the text for this errata please either remove it from the errata, set the requires_doc_text flag to minus (-), or leave a "Doc Text" value of "--no tech note required" if you do not have permission to alter the flag.

Otherwise to aid in the development of relevant and accurate release documentation, please fill out the "Doc Text" field above with these four (4) pieces of information:

* Cause: What actions or circumstances cause this bug to present.
* Consequence: What happens when the bug presents.
* Fix: What was done to fix the bug.
* Result: What now happens when the actions or circumstances above occur. (NB: this is not the same as 'the bug doesn't present anymore')

Once filled out, please set the "Doc Type" field to the appropriate value for the type of change made and submit your edits to the bug.

For further details on the Cause, Consequence, Fix, Result format please refer to:

https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes 

Thanks in advance.
Comment 15 errata-xmlrpc 2014-01-21 14:35:21 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0033.html

Note You need to log in before you can comment on or make changes to this bug.