Bug 971677 - keeps forgetting the org.gnome.desktop.interface.enable-animations setting
keeps forgetting the org.gnome.desktop.interface.enable-animations setting
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnome-settings-daemon (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
: 992924 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-07 02:43 EDT by Ales Kozumplik
Modified: 2014-09-30 19:41 EDT (History)
17 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-13 15:01:21 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Bugzilla 694692 None None None Never

  None (edit)
Description Ales Kozumplik 2013-06-07 02:43:37 EDT
Steps to Reproduce:
1. dconf-editor, 
2. disable org.gnome.desktop.interface.enable-animations

Actual results:

animations are disabled works for a while but after some time (reboot?) the setting is reset and animations are back.

Expected results:
the setting is retained between sessions.
Comment 1 Bojan Smojver 2013-06-12 19:20:16 EDT
In my experience, this is only the case when llvmpipe is not in use. I have a VM where llvmpipe is used and this setting is remembered correctly there. Annoying on my Intel graphics machine where I don't want animations either, but they keep coming back.
Comment 2 Florian Müllner 2013-06-13 17:17:02 EDT
gnome-shell only ever reads that setting, so the bug must be elsewhere. Are there any errors about dconf in the logs? It does sound like the on-disk db is either not writable or gets wiped on reboot ...
Comment 3 Bojan Smojver 2013-06-14 00:43:22 EDT
The files are definitely writeable. Changing anything else in org.gnome.desktop.interface will work. Changing this setting using gsettings or dconf also works. It just that at the next login it is switched back by something.

Wasn't there a piece of code introduced recently that checks whether the rendering is of the slow kind (VNC, remote or some such) and then automatically turns off animations? Maybe that same code turns is back on.
Comment 4 Bojan Smojver 2013-06-14 00:56:57 EDT
(In reply to Bojan Smojver from comment #3)
 
> Wasn't there a piece of code introduced recently that checks whether the
> rendering is of the slow kind (VNC, remote or some such) and then
> automatically turns off animations? Maybe that same code turns is back on.

gnome-settings-deamon, remote-display plugin, I believe.
Comment 5 Bojan Smojver 2013-06-14 01:03:35 EDT
Workaround:

gsettings set org.gnome.settings-daemon.plugins.remote-display active false

Followed by:

gsettings set org.gnome.desktop.interface enable-animations false
Comment 6 Jes Sorensen 2013-08-19 12:20:00 EDT
*** Bug 992924 has been marked as a duplicate of this bug. ***
Comment 7 Jes Sorensen 2013-12-10 05:17:36 EST
This problem is still present in Fedora 20 - this is utterly frustrating!

These animations are all very pretty at first logon, but after 5 minutes
of usage we have seen them plenty and it would be nice if we could focus
on using the computer instead without these annoying delays when switching
display.

Yes there is a workaround listed about, but that is a hack and not a proper
solution.
Comment 8 Bojan Smojver 2013-12-10 17:34:17 EST
(In reply to Jes Sorensen from comment #7)
> This problem is still present in Fedora 20 - this is utterly frustrating!

Yeah, but check out bug #973486 - that's doubly frustrating. Even the simple workaround (disable relevant plugin) stopped working, so I had to come up with an idiotic hack to make it work (and no, disabling RANDR for Xvnc does not work - Gnome just cannot work with X like that, it seems).

> These animations are all very pretty at first logon, but after 5 minutes
> of usage we have seen them plenty and it would be nice if we could focus
> on using the computer instead without these annoying delays when switching
> display.

From your mouth to Gnome's developers' ears! I hope that when people with Red Hat e-mail address speak, someone will eventually listen. :-)

Note You need to log in before you can comment on or make changes to this bug.