Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 971738 - Password for katello-configure as "test" provides incorrect response message.
Password for katello-configure as "test" provides incorrect response message.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management (Show other bugs)
6.0.4
Unspecified Unspecified
unspecified Severity unspecified (vote)
: Unspecified
: Unused
Assigned To: Mike McCune
Og Maciel
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-07 04:13 EDT by Wade Mealing
Modified: 2014-04-24 13:11 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Wade Mealing 2013-06-07 04:13:59 EDT
Description of problem:

When using katello-configure with --user-pass=test

Katello responds:

Option[Katello user's password (--user-pass)] not correctly specified.

Version-Release number of selected component (if applicable):

katello-configure-1.4.3-14.el6sat.noarch (Nice version yo, whats up with that)

How reproducible:

Every time

Steps to Reproduce:
1. Install sat 6 katello 
2. Use the command line katello-configure --user-pass=test
3. Wait

Actual results:

Option[Katello user's password (--user-pass)] not correctly specified.

Expected results:

Option[Katello user's password (--user-pass)] The password supplied is not secure enough, please choose another password"

Additional info:

This may be something which works the second or third time, as I had tried a few times to use katello-configure and it only worked when given a longer and more secure password.

This could become a significant burden on GSS if an error message like this goes through.  I bet a lot of admins test with the password "test".
Comment 1 RHEL Product and Program Management 2013-06-12 14:33:45 EDT
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.
Comment 3 manjiri tapaswi 2013-10-11 14:46:41 EDT
PR: https://github.com/mccun934/katello-configure/pull/1
Comment 4 manjiri tapaswi 2013-10-11 15:21:11 EDT
(In reply to manjiri tapaswi from comment #3)
> PR: https://github.com/mccun934/katello-configure/pull/1


UPDATED PR: https://github.com/Katello/katello-installer/pull/56
Comment 5 manjiri tapaswi 2013-10-11 15:42:23 EDT
(In reply to manjiri tapaswi from comment #4)
> (In reply to manjiri tapaswi from comment #3)
> > PR: https://github.com/mccun934/katello-configure/pull/1
> 
> 
> UPDATED PR: https://github.com/Katello/katello-installer/pull/56



Apologies for posting incorrect links.

PR: https://github.com/Katello/katello-installer/pull/57
Comment 6 manjiri tapaswi 2013-10-14 16:50:43 EDT
Commit: 2d2c298
Comment 9 Og Maciel 2013-10-21 16:23:14 EDT
The fix is to disallow insecure passwords during config.

Verified:

* apr-util-ldap-1.3.9-3.el6_0.1.x86_64
* candlepin-0.8.25-1.el6sam.noarch
* candlepin-scl-1-5.el6_4.noarch
* candlepin-scl-quartz-2.1.5-5.el6_4.noarch
* candlepin-scl-rhino-1.7R3-1.el6_4.noarch
* candlepin-scl-runtime-1-5.el6_4.noarch
* candlepin-selinux-0.8.25-1.el6sam.noarch
* candlepin-tomcat6-0.8.25-1.el6sam.noarch
* elasticsearch-0.19.9-8.el6sat.noarch
* foreman-1.3.0-18.el6sat.noarch
* foreman-compute-1.3.0-18.el6sat.noarch
* foreman-libvirt-1.3.0-18.el6sat.noarch
* foreman-postgresql-1.3.0-18.el6sat.noarch
* foreman-proxy-1.3.0-3.el6sat.noarch
* katello-1.4.6-39.el6sat.noarch
* katello-all-1.4.6-39.el6sat.noarch
* katello-candlepin-cert-key-pair-1.0-1.noarch
* katello-certs-tools-1.4.4-1.el6sat.noarch
* katello-cli-1.4.3-24.el6sat.noarch
* katello-cli-common-1.4.3-24.el6sat.noarch
* katello-common-1.4.6-39.el6sat.noarch
* katello-configure-1.4.7-5.el6sat.noarch
* katello-configure-foreman-1.4.7-5.el6sat.noarch
* katello-configure-foreman-proxy-1.4.7-5.el6sat.noarch
* katello-foreman-all-1.4.6-39.el6sat.noarch
* katello-glue-candlepin-1.4.6-39.el6sat.noarch
* katello-glue-elasticsearch-1.4.6-39.el6sat.noarch
* katello-glue-pulp-1.4.6-39.el6sat.noarch
* katello-qpid-broker-key-pair-1.0-1.noarch
* katello-qpid-client-key-pair-1.0-1.noarch
* katello-selinux-1.4.4-4.el6sat.noarch
* openldap-2.4.23-31.el6.x86_64
* pulp-katello-plugins-0.2-1.el6sat.noarch
* pulp-nodes-common-2.3.0-0.22.beta.el6sat.noarch
* pulp-nodes-parent-2.3.0-0.22.beta.el6sat.noarch
* pulp-puppet-plugins-2.3.0-0.22.beta.el6sat.noarch
* pulp-rpm-plugins-2.3.0-0.22.beta.el6sat.noarch
* pulp-selinux-2.3.0-0.22.beta.el6sat.noarch
* pulp-server-2.3.0-0.22.beta.el6sat.noarch
* python-ldap-2.3.10-1.el6.x86_64
* ruby193-rubygem-ldap_fluff-0.2.2-2.el6sat.noarch
* ruby193-rubygem-net-ldap-0.3.1-3.el6sat.noarch
* ruby193-rubygem-runcible-1.0.7-1.el6sat.noarch
* signo-0.0.22-2.el6sat.noarch
* signo-katello-0.0.22-2.el6sat.noarch
Comment 11 Bryan Kearney 2014-04-24 13:10:50 EDT
This was verified and delivered with MDP2. Closing it out.
Comment 12 Bryan Kearney 2014-04-24 13:11:56 EDT
This was delivered and verified with MDP2. Closing the bug.

Note You need to log in before you can comment on or make changes to this bug.