Bug 971758 - oauth error from pulp_rest in production.log
oauth error from pulp_rest in production.log
Status: CLOSED NOTABUG
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management (Show other bugs)
6.0.1
Unspecified Unspecified
unspecified Severity medium (vote)
: Unspecified
: --
Assigned To: Eric Helms
Katello QA List
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-07 04:39 EDT by Sachin Ghai
Modified: 2013-09-17 17:10 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-17 10:28:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
logs (379.83 KB, application/gzip)
2013-06-07 09:55 EDT, Garik Khachikyan
no flags Details

  None (edit)
Comment 2 Ivan Necas 2013-06-07 09:47:32 EDT
Was the system working properly at the end? The message in the log doesn't have to mean much, if only that it says is that the user is already created.

Also, katello-debug output would be a big plus.
Comment 4 Garik Khachikyan 2013-06-07 09:53:37 EDT
btw: I also see the same log piece there in my install.
but despite of this my system is functional.
Comment 5 Garik Khachikyan 2013-06-07 09:55:06 EDT
Created attachment 758171 [details]
logs
Comment 7 Sachin Ghai 2013-06-10 03:27:55 EDT
thanks Garik for sharing the logs.

Ivan, So far system is behaving properly.
Comment 9 Eric Helms 2013-06-17 09:45:33 EDT
This is not truly a bug. I'll try to explain why every user sees this. 

When we seed the database at installation or development environment setup, we create a number of entities. In this case, we are creating an initial user in the Katello database named 'admin'. By default, when Pulp is installed, Pulp creates and establishes an admin user with the username 'admin'. When Katello goes to create it's initial admin user, this triggers an attempt to create a user named 'admin' in the Pulp database. Since an admin user already exists, a 409 conflict is thrown. Katello logs all non-successful calls to Pulp in the production log (unless the user tweaks the logging settings) and thus you see this issue. 

If you named the initial user something other than admin, you should not see this message. To prevent this single message from appearing, we'd have to add some custom logic to just to account for this particular scenario.
Comment 10 Garik Khachikyan 2013-06-17 09:51:31 EDT
Thanks Eric for the description.

Actually I confirm: functionality is not getting broken with this "error".

For avoiding confusion I would recommend to make ERROR -> WARNING maybe?

Anycase: it is definitely not a 6.0.1 issue :) fixing to 6.0.2. thanks.
Comment 11 Eric Helms 2013-06-17 10:28:36 EDT
Currently, we log all exceptions at the layer that handles the Pulp API calls. Extracting out this single situation to log as a warning instead of an error would be difficult with our current setup. While conflicts in Pulp are not necessarily indicative of an error, they are good forensic evidence in the event of a bigger issue being logged by Katello. Closing in light of the above.

Note You need to log in before you can comment on or make changes to this bug.