Bug 971769 - AVC denial would generate in audit.log when ssh into an app
AVC denial would generate in audit.log when ssh into an app
Status: CLOSED DUPLICATE of bug 966876
Product: OpenShift Container Platform
Classification: Red Hat
Component: Containers (Show other bugs)
1.2.0
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Brenton Leanhardt
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-07 04:52 EDT by Gaoyun Pei
Modified: 2017-03-08 12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-07 08:26:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gaoyun Pei 2013-06-07 04:52:21 EDT
Description of problem:
When ssh into an app, avc denial would generate in audit.log

Version-Release number of selected component (if applicable):
http://buildvm-devops.usersys.redhat.com/puddle/build/OpenShiftEnterprise/1.2/2013-06-06.1/
selinux-policy-targeted-3.7.19-195.el6_4.6.noarch
selinux-policy-3.7.19-195.el6_4.6.noarch


How reproducible:
Always

Steps to Reproduce:
1.Create an app and ssh into it, at the same time, monitor avc message on node


Actual results:
[root@node1 ~]# tailf /var/log/audit/audit.log|grep avc

type=AVC msg=audit(1370594282.953:117705): avc:  denied  { search } for  pid=3130 comm="sshd" name="cgroup" dev=dm-0 ino=5681 scontext=system_u:system_r:sshd_t:s0-s0:c0.c1023 tcontext=system_u:object_r:cgroup_t:s0 tclass=dir
type=AVC msg=audit(1370594283.002:117706): avc:  denied  { getattr } for  pid=3255 comm="oo-namespace-in" path="/var/lib/openshift/51b192320f5b15a45d00007d/.env/CARTRIDGE_VERSION_2" dev=dm-0 ino=24925 scontext=system_u:system_r:sshd_t:s0-s0:c0.c1023 tcontext=system_u:object_r:openshift_var_lib_t:s0 tclass=file


Expected results:
No error message is seen

Additional info:
Comment 2 Jason DeTiberus 2013-06-07 08:26:46 EDT

*** This bug has been marked as a duplicate of bug 966876 ***

Note You need to log in before you can comment on or make changes to this bug.