Bug 97177 - scsi driver shutdown with iomega zip plus parallel drive
scsi driver shutdown with iomega zip plus parallel drive
Status: CLOSED DUPLICATE of bug 91381
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
8.0
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-06-11 03:47 EDT by Caeies
Modified: 2007-04-18 12:54 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:56:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
the script output for the command with the exact errors (8.44 KB, text/plain)
2003-06-11 11:21 EDT, Caeies
no flags Details
the kernel message from /var/log/message (1.36 KB, text/plain)
2003-06-11 11:22 EDT, Caeies
no flags Details

  None (edit)
Description Caeies 2003-06-11 03:47:08 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
The new release of the kernel (20-18.8) give me a big pblm with my iomega drive.
it is well recognize when I load the module (imm.o), but when I do the mount
command the module wait 10/20 seconds saying that it attached scsi0 to sda (or
something like that) with id 5 and then recognize the disk but can't read the
fat partition (but it can with the 18-26.8.0 release !)
the kernel said that scsi timout the removable disk at scsi0 lun=? id=5 is
shutdown after bus reset
I'll try to give you exact messages in the afternoon.
My zip drive is a iomega 100 zip plus on the parallel port, I never had pblm
with it under RH before.

Version-Release number of selected component (if applicable):
kernel-2.4.20-18.8

How reproducible:
Always

Steps to Reproduce:
1.modprobe imm.o 
2.mount /mnt/zip
3.wait and see :)
    

Actual Results:  the system recognize the iomega drive, partially the disk (a
100 meg well formatted) and then say it can't read the partition table and the
kernel complaint about a scsi timeout after a bus reset and consider the driver
as shutdown

Expected Results:  To mount the zip drive without problem

Additional info:
Comment 1 Caeies 2003-06-11 11:21:34 EDT
Created attachment 92338 [details]
the script output for the command with the exact errors

only the output of the command listed in the step to reproduce the bug, with I
hope some usefull information (more precise error log :)
Comment 2 Caeies 2003-06-11 11:22:46 EDT
Created attachment 92339 [details]
the kernel message from /var/log/message

The message saying driver shutdown or retry fail after a bus reset
Comment 3 Caeies 2003-06-11 11:31:32 EDT
Sorry to be not clear in the first release of the bug.
I try to recompile the module with some DEBUG information(add a -DDEBUG to the
scsi drivers), but doesn't seem to be more interresting ... But if you need it
tell me and i'll give you as much info as i can.
I have check if the problem could come from the parport_pc.c or file something
like that but nothing relevant have been change in this file, so it's certainly
in the scsi drivers that the bug is... I'll reboot my computer with the old
2.4.18-26 kernel and all was nice the imm works well and i can read my zip disk...
More about my computer :
A Compaq 6200EA :)
(athlon XP1700+ with 256 Mo RAM and nvidia geForce/motherboard)
notice: the kernel was not tainted because I don't use the nvidia drivers to
make the test :)
Thank you for your help,
Caeies
Comment 4 chrisw 2003-06-12 17:38:36 EDT
refer to my post under bug #91381

this might help things
Comment 5 Caeies 2003-06-14 11:02:37 EDT
The solution proposed by 91381 solves my problem. But like he says, I think that
is not the bug, but I'm not an expert ...

*** This bug has been marked as a duplicate of 91381 ***
Comment 6 Red Hat Bugzilla 2006-02-21 13:56:40 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.