This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 97180 - NFS fails to permit remote mounts
NFS fails to permit remote mounts
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: nfs-server (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Michael K. Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-06-11 05:34 EDT by Crutcher Dunnavant
Modified: 2007-04-18 12:54 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-14 04:43:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Crutcher Dunnavant 2003-06-11 05:34:10 EDT
Description of problem:

I have a collection of RHL 9 boxes in a lab environment. I am exporting /home
and /var/spool/mail over nfs, using the following export file:



&/root&
# cat /etc/exports
/var/ftp/pub             *(ro,insecure,async,all_squash)
/var/ftp/pub            
130.160.20.0/255.255.255.0(rw,insecure,async,no_root_squash)
/home                    *.unix.eng.ua.edu(rw,insecure,async,no_root_squash)
/home                   
130.160.20.0/255.255.255.0(rw,no_root_squash,insecure,async)
/var/spool/mail          *.unix.eng.ua.edu(rw,insecure,async,no_root_squash)
/var/spool/mail         
130.160.20.0/255.255.255.0(rw,insecure,async,no_root_squash)
/home/student/crutcher   monket.dyndns.org(rw,insecure,async)


After applying the latest set of updates, to client and servers, I am getting
the following error, intermittently, on mount attempts:

# On the client side:
[root@ho-l06 root]# mount /home
mount: home.unix.eng.ua.edu:/home failed, reason given by server: Permission denied

# From /var/log/messages on the server
Jun 11 04:23:06 mule rpc.mountd: authenticated mount request from
ho-l06.unix.eng.ua.edu:877 for /home (/home) 
Jun 11 04:23:06 mule rpc.mountd: getfh failed: Operation not permitted 

These machines are all in the unix.eng.ua.edu domain, and all use the following
hosts.allow file:
&/var/log&
# cat /etc/hosts.allow 
#
# hosts.allow   This file describes the names of the hosts which are
#               allowed to use the local INET services, as decided
#               by the '/usr/sbin/tcpd' server.
#

statd: .unix.eng.ua.edu
mountd: .unix.eng.ua.edu

The clients use the following fstab file:
LABEL=/                 /                       ext3    defaults        1 1
LABEL=/boot             /boot                   ext3    defaults        1 2
none                    /dev/pts                devpts  gid=5,mode=620  0 0
none                    /proc                   proc    defaults        0 0
none                    /dev/shm                tmpfs   defaults        0 0
/dev/hda3               swap                    swap    defaults        0 0
/dev/cdrom              /mnt/cdrom              udf,iso9660
noauto,owner,kudzu,ro 0 0
/dev/fd0                /mnt/floppy             auto    noauto,owner,kudzu 0 0
home.unix.eng.ua.edu:/home      /home                   nfs    
async,rsize=8192,wsize=8192     0 2
home.unix.eng.ua.edu:/var/spool/mail    /var/spool/mail         nfs    
async,rsize=8192,wsize=8192     0 2

There is NO /etc/sysconfig/nfs file on these systems. nfs and nfslock are
configured to run, and status reports that they are.

These machines are current as of this posting with RHL9 and all updates, applied
through redhat network on the account 'rhnunival'. There are still some old
RHL8.0 profiles in that account, as I am in the middle of a migration that is
taking entirely too long.


This worked before applying the updates. I am very concerned about this, I have
tried many things, but have identified very few common threads.

First, after a reboot, the server seems to permit mounts to home for a while.
Then it stops. Once it stops, it never starts again. However, I have seen no
similar problems with /var/spool/mail mounts.


I have searched bugzilla for relevent bugs, and found nothing that pertains to
this problem. I am willing and able to do sersious debuging in my environment,
if I am given direction on how to do it. I do not possess NFS debugging
knowledge, or I would have given a better report here.

I will be forced to roll back updates on the server tomorrow, in an effort to
find a functional state for the system. At this point even a work-arround would
do, my computer network does not work at all right now, locking out about 150
college students from their linux accounts.
Comment 1 Crutcher Dunnavant 2003-06-14 04:43:38 EDT
This is some kind of interaction with nfs and symlinks. I had some external
locations (/var/ftp and /var/spool/mail) linked to locations in, and between
these being exported, and the links, NFS was getting confused. Since a client
box would mount /home FIRST, then /var/spool/mail, it worked the FIRST time.
Setting no_subtree_checks in the exports file didn't help, though.

Still having Stale NFS filehandle bugs, but that is a different issue.

Closing this, I guess.

Note You need to log in before you can comment on or make changes to this bug.